New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus support has failed me so someone please help

RastVrRastVr Posts: 2
NerveGear
After getting my oculus rift s It worked great for a few weeks and then randomly stopped working while i was using it since then, it will rarely detect my display port. If it does detect my display port it will get stuck on the sensor check. If i skip the sensor check it will says its connected and active but that it still cant find my display port and sometimes it says it cant find my usb as well. ive contacted support twice and they havent been any help at all so should i just give up and try to return this garbage or is there a way to fix it . 

Comments

  • adam.poole.313adam.poole.313 Posts: 154
    Art3mis
    Everybody is having this problem now (among others.)  Of course its impossible to rule out some other issue, but Oculus released a terribly botched driver back in december and every driver release since then has failed to completely fix its issues. I never saw this problem until that driver release (version 12.)

    Some people have had luck using a USB card instead of the motherboard USB slots, others have accomplished the same using a powered USB hub. Many, like myself, still cannot fix the problem even when using these options. If you don't want to go this route, or resent having to spend more money to fix Oculus' mistake and horrible handling of it, then there is a drastic solution that should work.


    Go back to the last good driver and I will bet your rift will work perfectly again. If you go this route make sure and post back here and also tell Oculus through a support ticket about your results. Oculus refuses to abandon this doomed driver. The more this fix gets published the more embarrassing it is for them how inept they are. Maybe someday they will just go back to driver 1.43 and rebuild it correctly to add in the new features instead of looking for the needle in the haystack that's causing this problem.

    Oculus Rift S, CV1
    Intel i7-8700K
    ASUS ROG Maximus X Hero
    16GB DDR4 x 2
    4 TB SDD, 2 TB SSD, 1 TB SSD
    Windows 10 Home
  • gene.cullupgene.cullup Posts: 5
    NerveGear
    I kept loosing controller connection, until I plugged into a usb 3.1 gen 2 plug instead of a usb 3.1 gen 1? I have had no problems since. Maybe? Because first the usb should be plugged in then the display port. Are you on a discreet graphic card?
  • RastVrRastVr Posts: 2
    NerveGear
    Everybody is having this problem now (among others.)  Of course its impossible to rule out some other issue, but Oculus released a terribly botched driver back in december and every driver release since then has failed to completely fix its issues. I never saw this problem until that driver release (version 12.)

    Some people have had luck using a USB card instead of the motherboard USB slots, others have accomplished the same using a powered USB hub. Many, like myself, still cannot fix the problem even when using these options. If you don't want to go this route, or resent having to spend more money to fix Oculus' mistake and horrible handling of it, then there is a drastic solution that should work.



    Go back to the last good driver and I will bet your rift will work perfectly again. If you go this route make sure and post back here and also tell Oculus through a support ticket about your results. Oculus refuses to abandon this doomed driver. The more this fix gets published the more embarrassing it is for them how inept they are. Maybe someday they will just go back to driver 1.43 and rebuild it correctly to add in the new features instead of looking for the needle in the haystack that's causing this problem.

    yeah i tried that already and it still just doesnt work no matter what i do. Im probably just gonna refund it and save up for a vive instead tbh. 
Sign In or Register to comment.