New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Headset sensor tracking failed on rift S

I’ve tried troubleshooting the oculus software for 15 hours now and I always get stuck on the same thing: the headset sensor check infinantly loads. I skipped the setup, and now I also have a problem where it tells me I need to restart, and when I do it’s still saying I need to restart. I’ve tried:

Updating all my drivers

Updating windows 

Updating oculus firmware

Switching to public test channel

Different USB ports

Disconnecting and reconnecting the tether on the headset and the pc 

Restarting many many times

Disabling my firewall and any kind of malware protection 

Made sure my camera permission is on

Returned and swapped for a different rift S

Uninstalling and redownloading the oculus software 

Repairing the oculus software.

Any other things I should try? Any help would be massively appreciated


  • xAstroBoyxAstroBoy Posts: 7
    Brain Burst
    Is the oculus software that messed up with the latest update, no rift S works, try to go to Public Beta Channel, if else nothing works,  wait for oculus to fix the software issue.
  • MaxxgoldMaxxgold Posts: 521
    Has it ever worked? If not, then you need a USB cards.  Try the above solution as well. 
  • 3xcelsi0r3xcelsi0r Posts: 1
    I got the same troubles... yesterday everything worked fine and now I can't get it running again. My whole PC doesn't even recognize my Rift S
  • cronicburncronicburn Posts: 7
    well to fix the restart right click on the windows button go to device manager do to the universal bus thing and if you see 2 rift s hub usb things u are good but if u only see 1 unplug and replug usb back in until u have 2 it worked for me but i have a blackout and crash problem now and oculus support responded with nothing relevant to my situation. i might as well get an htc vive. 
  • cronicburncronicburn Posts: 7
    go* to the universal bus thing
  • marco.a.rivera.227marco.a.rivera.227 Posts: 11
    My windows tries to install the second Rift sensor but fails, I even have bought the recommended USB 3.0 card on this site and still the Oculus software sees it as 2.0 reason windows cannot install the driver. My PC has now 8 USB 3.0 ports, if they can't fix the issue they at least should release the drivers so you can manually install them
Sign In or Register to comment.