New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Link not working after V20 update "PC not detected"

Hi all,

I've got both my oculus software and quest updated to the latest updates (v Everything was working fine before the most recent update. This is with the official oculus quest cable. The prevailing error is "PC Not Recognized" when in the Quest headset.

I have two USB-C ports, one on the back and one on the front. Used to work on the front before this update but I've tried both during troubleshooting getting this thing back up and running. Neither will work.

PC Specs:
Processor: Intel i7-8700K
GPU: 1080TI

Troubleshooting steps thus far:

  • Unplugged USB-C cable, restarted quest, launched oculus on PC and started quest.

  • Updated drivers and BIOS (including USB 3 and Thunderbolt on PC, Reboot, start Oculus software and plugged everything back in. Went to settings > device > quest link to receive same error.

  • Factory reset quest while charging, not connected to PC, reconnected Oculus link cable and received same error when trying to connect.

  • Factory reset again not connected to anything, went through setup on Quest, connected to PC and tried adding device via PC Oculus software (Never recognized USB C cable).

  • Rebooted PC and Quest with both disconnected. Launched PC Oculus app and then turned on Quest and USB-C cable connected (No prompt to allow files etc. and would not detect PC from device settings in Quest.)

  • Attempted reinstalling Oculus drivers from C:\programfiles\oculus\support\oculus-drivers.exe, rebooting oculus quest and tried connecting again. These steps were listed on the Oculus Quest Link support page.

I'm starting to think it may be the cable but it's so odd that it broke at the same time as the update. Is any one else experiencing this issue? I've opened a ticket with Oculus to see if they have anything to add, but I'm curious if someone has had similar issues and was able to resolve it. Everything I've tried has left me with "PC Not Detected" on the Quest side and when I try to add the device via Oculus App on my PC it just never detects a connection on the USB-C cable.


  • SpasticLlamaSpasticLlama Posts: 4
    Anyone else having this problem? I've got a support ticket open with Oculus but I'm curious if I'm one of the few that have been affected. 
  • MuXSenpaiMuXSenpai Posts: 4
    edited September 3
    I have a similar problem. I have used Link for hours, sometimes even straight 8 hours, without any problems. I after the update, however, I'm having USB detection issues and random disconnects.
    When I connect my link cable to a USB 3.0 port it fails to detect Quest, but still charges the device. Only plugging it to a USB 3.1 port works both for charging and Link. Yet, still it sometimes fails randomly and "Test Connection Speed" option gives an ERROR. For instance, my connection cut off suddenly an hour later while playing VRChat using. Also, I get weird reconnects. Like I said I didn't have a single problem before.
    I also realized in between USB disconnect sounds Quest gets detected and Enable Link button appears under Quick Settings, but quickly get disconnected. After several retries it just stops and switches to charging mode.

    AMD 2600X
    GTX 1060 6GB
    16GB RAM

    So far I tried:
    >Uninstalling and Reinstalling Oculus Software.
    >Uninstalling and Reinstalling Drivers.
    >Trying every single USB port I have before and after doing the mentioned above.
    >My drivers and BIOS are up to date.

  • navar5150navar5150 Posts: 2
    I am having the same issue as of this week. Link was working perfectly fine for me last week and prior, then this week stopped working with same issue as above, and I have changed nothing in my setup (6700k. gtx 1080 TI 16 GB). It is getting frustrating that this seems to be a pattern with updates unless this is somehow related to a Win10 update or GPU graphic drivers but I doubt it since this has happened in the past several times when there was a headset update then fixed in later update. It should be beyond a beta at this point and if the headset is getting an update they should be rolled out in tandem so it does not kill Link. Is there a fix in the works Oculus? Please help us out. 
  • SpasticLlamaSpasticLlama Posts: 4
    I have a somewhat happy update:

    Still working with Oculus Support. They asked that I test Oculus Link with the charging cable instead of the link cable. As soon as I plugged it in Oculus Link prompted to start up. Followed the prompts and I was able to successfully enable Link and use my desktop. I did not try games as the cable isn't long enough to keep me from hitting the ceiling fan. Looks like I may have received a faulty cable, or I somehow damaged it. Not sure how I could have damaged it as it was just sitting there plugged in with plenty of slack. No stress on the cable ends either.

    If anyone else is having issues with their official Link cable, try your charging cable and open a ticket with Oculus armed with your order number. I'll update if they end up replacing the cable.

  • MuXSenpaiMuXSenpai Posts: 4
    With further testing, i found out when ever i hit "test connection speed" Oculus Link gets disabled on the Quest side. Thus, giving me a testing fail. It used to show a black screen that mentions the running test and instructs to finish the connection speed test before returning to VR. I have tested to see if the cable is broken. It does work with my USB 3.1 ports for the Oculus Link and on all USB ports with my other Type-C devices. I tried testing with a USB 2.0 cable,  it did work with USB 3.0 ports this time, but connection speed test still fails and gives me an error.
  • Rosto79Rosto79 Posts: 12
    Same for me. It does work but the speedtest fails...
  • hodgeachodgeac Posts: 2
    Cable test is broken in the latest version of the app. But Link should be working regardless. I had various issues with Link pop up after the latest update, but I was able to work through them all. Bummer since it worked flawlessly before the update. I really hope I don't have to go through that every time I'm forced to update just to keep playing my games.
  • Rosto79Rosto79 Posts: 12
    I'll try again this evening if Link performance is on par with v19.. I tried it this weekend but I noticed stuttering .. which I normally don't have. So .. will report back with my findings. 
  • navar5150navar5150 Posts: 2
    Here is how I fixed the PC Not Detected issue based on another post. For version 20, start up the Oculus app on PC while the Quesst is connected (but powered off), power on the Quest, when the "allow access..." message in the Quest shows up, click "deny". Then go to the device menu in the Quest, and click enable Oculus Link Beta. That worked for me. I guess since this is still in Beta it pretty much has oddities in the process to get it working each time. Hope this helps others.
  • SuperUnknownDudeSuperUnknownDude Posts: 7
    Same problem here. Just tested it. Looks like testing cable speeds is a no-go on version 20. At least Link still functions, but I'll wait for the next patch where they fix the cable speed and break the Link functionality. :neutral:
  • RogueStargunRogueStargun Posts: 2
    I seem to have the same problem. The link is now an 80$ charging cable. My PC will not detect the link at all.
  • Thomas_LucineThomas_Lucine Posts: 5
    I hade the same problem and it did not came from the cables.

    I don't understand how that's even possible but the problem came from the windows updates. I soon as I updated windows 10, everything went back to normal...
    Anybody had the same thing ?
  • s4Luuxs4Luux Posts: 10
    Brain Burst
    Same problem. Even the cable compatibility check does not work at all anymore. Even with the charger cable.
  • Truthbringer76Truthbringer76 Posts: 2
    I have had issues as well. Didn't change anything on my setup either. I have latest Windows updates using official link cable. Tried 3 other cables and different ports on motherboard and add on card. I can get it to work but speed test definitely broken. I also tested on a second PC same issue.
  • SpasticLlamaSpasticLlama Posts: 4
    For another update, charging cable still works to get the "enable link" prompt in the headset. Official link cable does not. Oculus support asked for the serial number of the Link cable but it was on the box that I had thrown away already. 

    Today marks the 3 week point since I've had the ticket open with Oculus on this. The only update I've gotten, after not hearing anything for 5 days, was that it's still pending response from the team that handles serial keys. I provided the order number. I would have thought that it would have been proof enough I bought the darn thing. Was hoping to just buy a cable that was officially supported and spend the extra money for that support. The fact that it's taken this long has been frustrating a bit though.

    That aside, I'll still update with what happens. I hope everyone else's issues get resolved more quickly than mine has been. If you haven't already, open a support ticket with Oculus sooner than later. 
Sign In or Register to comment.