Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Unity 5: Reflection Probes don't work in build

BLACKISHBLACKISH Posts: 44
Brain Burst
edited October 2015 in Unity Development
Have a look at this test-scene. Reflections work just fine in the editor and with a normal camera, but as soon as I make a build and run it in VR, reflections are gone. I reported a bug to unity, but then again this might be something that oculus has to fix in the unity integration.

ReflectionProbesBug.png

Anyone else got this problem? Any ideas how to fix it?
BLACKISH (Games) | GameAssets.net (Assets)

Comments

  • BLACKISHBLACKISH Posts: 44
    Brain Burst
    Or this be a problem with RenderTextures in general?
    BLACKISH (Games) | GameAssets.net (Assets)
  • BLACKISHBLACKISH Posts: 44
    Brain Burst
    It's not. RenderTextures are fine on their own. Is the oculus integration doing anything special with render-textures that makes it go wrong?
    BLACKISH (Games) | GameAssets.net (Assets)
  • weasel47weasel47 Posts: 301
    Trinity
    I've installed almost every Unity 5 beta as they came along, and the behavior of reflection probes has changed several times. They were finally working for awhile and then they went back to being black (like in your screenshots) with the latest version I installed (release candidate 3). I haven't had a chance to investigate it. I believe release candidate 4 was the official public release, and I haven't tried that yet.
  • BLACKISHBLACKISH Posts: 44
    Brain Burst
    I first noticed this in f2 (but could have been a problem earlier) and the screenshots are from the final Unity release (5.0.0f4)
    BLACKISH (Games) | GameAssets.net (Assets)
  • HeadTripHeadTrip Posts: 164
    Hiro Protagonist
    I'm also seeing this... fine in editor, black in build
  • PoddenPodden Posts: 62
    Hiro Protagonist
    Rendertexture in general works. No problems with our OSD Textures.
    ______________________
    mySite
    www.darkfield-vr.com
  • deflixdeflix Posts: 56
    Hiro Protagonist
    same here - although mine is only black when the ovrplayer controller enters the reflection probe boundary.
    I must say that its disappointing that Oculus haven't timed a Unity 5 integration in conjunction with the official release of Unity 5 - this is a major fail imo. C'mon guys you're letting things slip.......dont let HTC and valve blow the wind out of your sails!
      "Behind every successful man is a woman rolling her eyes"
      -Jim Carrey
    • BaseDeltaZeroBaseDeltaZero Posts: 117
      Brain Burst
      Try this guys

      Hba6S9y.jpg
      AF.jpg
      Ambient Flight Eagle Flight Experience
      Dinosaur Voyage Running from Dinosaurs
    • HeadTripHeadTrip Posts: 164
      Hiro Protagonist
      Edit2: I got real time Reflection Probes working in Rift. I switched the probe's refresh Mode to: "Every frame".
      Is it working properly? not sure, but Its working, although every frame sounds expensive... The issue seems to be "on awake", or at least in my case. Very curious to see if this helps you

      EDIT: I do get the Reflection Probe to work in Rift using Type "Baked" and bake my reflection probe in the lighting panel.
      Just not dynamic yet. My object is dynamic so I assume the GI options dont apply (Static only).
    • mbzdmvpmbzdmvp Posts: 65
      Hiro Protagonist
      I can confirm that switching to Baked fixed this for me.

      Thanks HeadTrip!
      VR Jam 2015: Inside The Human Body
      Forum Post: viewtopic.php?f=77&t=23266
      V29IR5T.png
    • kideternalkideternal Posts: 38
      Brain Burst
      Baked probes work for me in DX11 mode, but not DX9 using Unity 5.0.0f4.

      Unfortunately, in DX11 my frame-rate seems capped @60FPS in the Rift using Direct mode. (It's 75FPS using DX9.)
    • BISBIS Posts: 1
      Hello Everyone !
      I just met with the same issue, real-time reflections do not work with Oculus Rift.
      But accidentally I have found solution, reflections start to work if anti-aliasing is disabled in the quality settings.
      Unfortunately can not explain why it happens, if someone have ideas please share it.
      Instead of anti-aliasing in the settings anti-aliasing image effect attached to the left and the right cameras can be used. Seems it gives slightly worse result but it is definitely better then nothing.
    • DakorDakor Posts: 22
      Brain Burst
      Hey,
      I got the same problem with the Unity5.0.1f1 release (and the 0.5.1 Mobile SDK) with a standalone PC build.

      Switching to baked reflections is no solution in my case. Disabling AA in quality settings works for me, but i hope this will get fixed in the near future.

      Thanks!
      Writer for Bloculus.de the German Virtual Reality Developer Blog
      Professional software developer for VR, Collector of old Gaming Hardware
    • KC130280KC130280 Posts: 24
      Brain Burst
      I ported my old unity 4 / dk1 scene to Unity 5 + dk2 and I am having issues with the reflection probe.

      Realtime / baked makes no difference. Both render black in the build but work fine in the editor.

      Checklist

      -I have AA disabledin the quality settings.
      -I have AA enabled as a post-processing effect works fine in the editor. Don't work in the build.
      -I have AA disabled as a post-processing effect works fine in the editor. Don't work in the build.
      -Eye texture anti aliasing set to 1
      -Continuous baking is enabled

      Specs
      I am using Unity Pro 5.0.1f1
      Standard Unlit shader for my ''baked'' textures. (light, shadows, ao, was baked in Mental ray)
      Standard Metallic shader for the ''reflective metallic and glossy dielectric surfaces''
      Standard emissive shader for the glowing surfaces.


      EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT

      Delete the probe. Plant a new anal probe and switch to Bake. This has worked for me.
    • I'm facing the exact same issue...

      I'm using Unity 4.6, and I have tested it on two computers.

      On my desktop (i7+8gb) with Windows 7 and GeForce GTX 610, the build works perfectly. On my laptop (Alienware i7+16gb) with Windows 8.1 and GeForce GTX 980M, the reflective surfaces turn black in the build. Even if I run the app using the default "Integrated Graphics" on the laptop, I get black surfaces.

      I need it to work on the laptop for better FPS and quality, but whatever I do, I can't seem to.

      At my wits end really. I am not able to move the scene to Unity 5 either as it creates more problems than it solves (missing shaders besides the black reflective surfaces problem).

      Any help will be deeply appreciated!
    • mugloremuglore Posts: 159
      Hiro Protagonist
      This seems to be the only thread on this bug, which is amazing. Getting this error as well using Oculus latest VR utilities package. The reflection probe and associated textures look fine in the editor when I bake the ref. probe, but as soon as I hit play, the ref. probe is cleared and all the textures appear black. This is sort of major as you're forced us to upgrade to Unity 5 (5.2.1f), it would be great to get some comment from Unity or Oculus on this.
      da1d63_abf76e211b61414dab29ba736ce87511.png?dn=sig_oculus.png
      Golf Masters DK2 Alpha, GOLF MASTERS
    • vrdavebvrdaveb Posts: 1,596 Oculus Staff
      Thanks. We are aware of the issue. Reflection probes are a little more involved than other view-dependent shaders and Unity appears to be using them with the wrong projection in VR. They're working on it. It should be fixed before too long. We'll give an ETA here as soon as we can settle on a fix.
    • mugloremuglore Posts: 159
      Hiro Protagonist
      I discovered a temp fix on the Unity forums that resolved my issue with reflection probes. The error seemed to result from the scene light bake being completed before the reflection probe was added and baked.

      I deleted the scene GI light bake, added the reflection probe, and re-rendered the light bake and now the reflection probe render will remain active throughout runtime and builds.
      da1d63_abf76e211b61414dab29ba736ce87511.png?dn=sig_oculus.png
      Golf Masters DK2 Alpha, GOLF MASTERS
    • isteffy1isteffy1 Posts: 1
      NerveGear
      I have the solution!

      In the Quality settings of Unity, the Quality level default settings is Fastest, which removes all reflections and adds other annoying aliasing.

      Change the Quality settings to 'Fantastic' and viola! Your reflections are back!
    Sign In or Register to comment.