Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

DK2 with 0.8 Runtime Viable (or even able) to Run 1.3 SDK Products?

MyDreamORMyDreamOR Posts: 10
NerveGear
We're currently working on a project that takes older games and makes them playable with HMDs, and we've updated to 1.3 SDK. We had the team update to the 1.2 runtime.

Unfortunately since we are a remote studio, we could only allocate DK2s to most of the team and our CV1 is dedicated to the project lead. With the 1.2 runtime, the DK2 doesn't appear to work with anything outside Oculus Store and World Demo scene (SteamVR and our product don't pick it up at all) which makes testing and development with the DK2s rather impossible.

Can we use the 0.8 runtime on the DK2 and expect full functionality with the product, now that it has been updated to 1.3 SDK? Otherwise will it be compromised but still usable with some minor errors? 

Comments

  • YbalridYbalrid Posts: 247
    Art3mis
    For me 1.3 works fine on DK2. If your team update your rendering code to 1.3 you should be able to run demo of the same binary on both CV1 and DK2...
    CV1+Touch; Running on GTX980 - 4770K - 32GB DDR3

    I'm writing a C++ open-sourcre game engine for the Rift http://annwvyn.org/ - https://github.com/Ybalrid/Annwvyn
    For now it's only used for my student projects at my engineering school http://en.esiea.fr/
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    No, Runtime 1.3 is not backwards compatible with older SDKs. However, you can still attempt to use DK2 with 1.3 content (it's technially unsupported, and may or may not work depending on what you're doing).
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • thewhiteambitthewhiteambit Posts: 282
    Art3mis
    I just wanted do ask if 1.3SDK will run on 0.8Runtime. Tested it, found out it does not. Wanted to test with 1.3Runtime - am I totally stupid, why can't I find 1.3Runtime in the 1.3SDK or somewere else for download?
  • crramirezcrramirez Posts: 1
    NerveGear
    edited March 2016
    @thewhiteambit you are not stupid, but the runtime it is difficult for us whose don't have the quickstart which comes with Oculus CV1. You can find the address in the user guide in the support tab. This is the link: https://www.oculus.com/en-us/setup/ I spent nor less of 10 minutes to find it.
  • thewhiteambitthewhiteambit Posts: 282
    Art3mis
    yeah, my thread on this got 400+ views :D solved it short after posting...
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Yes, the latest runtime is really hard to find. We are working on getting this placed on the site somewhere visible. For now you just kind of have to either have seen the URL (it comes in the Rift box) or search the forum. Sorry for the confusion.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • MyDreamORMyDreamOR Posts: 10
    NerveGear
    Ahh yeah saw the other threads about this and figured it out. :) I didn't realize the 1.3 runtime wasn't just waiting in the Downloads part of the Oculus website, but I eventually found the setup link.

    Thanks all!
Sign In or Register to comment.