New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Validator errors for samsung gear VR unity 3D

Hello everyone,
i'm trying to run my apk package on the submission validator, i've got one error and one warning.
let's begin with the error,

here, i want to know what SDK it wants me to update, i used occulus utilities for unity 5, i don't really remember the version but it was in january. and if it wants me to update the utilities how can i update it in my project. :neutral:  :neutral: 

and the warning is :

but in my androidmanifest.xml
i wrote   <uses-feature android:glEsVersion="0x00030000" android:required="true" />
and in my build settings i use in Texture Compression ETC2 (GLES 3.0)

thank you in advance.



Comments

  • chrispruettchrispruett Posts: 172 Oculus Staff
    Hi there,

    The GLES warning is probably a bug in the validation tool that you can ignore.

    The sdk warning, however, is not. Building with the latest SDK requires using a recent version of Unity itself, not just the Oculus Utilities package. The SDK actually comes with Unity. I recommend 5.3.4.
  • FmegrahiFmegrahi Posts: 11
    thank you,
    i fixed the SDK problem ! i updated unity and the utilities. 
    for the GLES warning i'm gonna ignore it. 
    have a nice day ! 
  • jbossjboss Posts: 9
    NerveGear
    I am getting the same SDK version error (must be later than version 1.0.0) with Unity 5.3.5 and version 1.5.0 of the Oculus Utilities.

    As a check, I ran the Oculus360PhotoSDK.apk that is included in the Mobile SDK 1.0.3 against the validator tool and got the same error (plus 3 more: apk is launchable, intent filter must be info and excude from recent must be non-0).

    So is my app wrong or is the validator tool wrong? Or can I simply submit the app and ignore the validator tool error.

    Thanks.
  • FulbyFulby Posts: 184
    Art3mis
    Are you using the exact version of Unity recommended in https://forums.oculus.com/developer/discussion/25882/recommended-unity-versions-for-development/p1

    When you submit the app it does some of the same validation automatically so I'd just submit and see what the website reports.
  • delphinius81delphinius81 Posts: 297
    Nexus 6
    The updated Oculus sdk is in one of the Unity patch releases (I think p4 or p5 added it). So you need to be running the latest patch version (5.3.5p6), not just the latest base version (5.3.5f1), in order to get the most recent SDK version into your builds.
  • jbossjboss Posts: 9
    NerveGear
    edited July 2016
    Even with 5.3.5p6 I still get the validator error that it's not built with version 1.0.0 or newer.

    I also get a message that it can not find 'C:\OpenSSL\openssl.cnf'. In the standard installation that I downloaded it is in 'C:\OpenSSL\bin\openssl.cnf'. So maybe the tool needs to be updated to use that location? Moving it to C:\OpenSSL\openssl.cnf did not remove the SDK error.
    <edited to change my somewhat frustrated comment into something more constructive....>
Sign In or Register to comment.