New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Oculus CV1 in Unity Editor Not Working

Hello,

I've had the CV1 headset of Oculus for a couple weeks and I've had the issue where I cant use it in the Unity Editor. Previously I had been using DK2 and everything worked perfectly, but with the new headset I get the error message "[VR Device] Initialization of oculus device failed". The only way for my to test any changes I've made in my scene is by building the .exe and running it which is annoying. Is it not meant to work in the editor anymore or have i missed a step?

My current setup is:
Unity 5.3.4p4
Oculus SDK for Windows v1.3.2
Oculus Utilities for Unity 5 v1.3.2
OVRPlugin for Unity 5.3 v1.3.2

As suggested in the OVRPlugin documentation I have deleted Unity's contents in the C:\Program Files\Unity\Editor\Data\VR\oculus folder and replaced it with the extracted content from the OVRPlugin.

Thanks!

Comments

  • vrdavebvrdaveb Posts: 1,596 Oculus Staff
    That should work, especially if there's no problem with standalone builds. As long as you have subfolders there named android, macosx32, macosx64, universal, win32, and win64, then it should work. Do you have some other copy of LibOVRRT or OVRPlugin next to Unity.exe or inside your project?
  • @vrdaveb I have all the subfolders you mentioned. I checked for "LibOVRRT" in my project and entire computer and do not have it. There is 1 OVRPlugin.cs file in my project, 1 OVRPlugin File in each of the subfolders you mentioned along with an OVRPlugin.dll. Nothing next to Unity.exe Could LibOVRRT be the issue?
  • petereptpeterept Posts: 170
    Art3mis
    I use Unity 5.3.4p1 as 5.3.4p4 is not officially supported yet AFAIK.

    Everything else you list sounds good. You could remove everything and re-install.

    I wrote up the full steps below:

    http://talesfromtherift.com/build-your-first-vr-app-for-the-oculus-rift/

    Peter
    Check out my Unity VR development blog:
    http://talesfromtherift.com
    @peterept
  • @peterept I'll attempt the uninstall and re-install everything in a couple of days since right now is not a good time for me to do that and I will update this post on if it worked or not. Thanks though! It's great to know that it is at least working for someone else.
  • @peterept @vrdaveb I have tried the uninstall and re-install of both unity and Oculus and I'm  still getting same results as mentioned above. I even removed oculus utilities from my project and re-imported it. I have no clue what else it could be :/
Sign In or Register to comment.