Unity unable to find libaudiopluginoculusspatializer — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Unity unable to find libaudiopluginoculusspatializer

Hello there.
I keep having this error appearing in Adb Monitor's console after removing the GearVr and put it on back again. In that exact moment, the game crashes ("Application closed unexpectedly") and this is the only error line that appears.
We have never needed this libaudiopluginoculusspatializer before, and had no problem after putting the GearVR back on, that is why I find this error kind of sudden. 

Could any of you tell me where can I find this libaudiopluginoculusspatializer or give me any hint?
We are currently working on Unity 5.3.6p4.

Thank you very much in advance.

Tagged:

Comments

  • vrdavebvrdaveb Posts: 1,596 Oculus Staff
    Strange, it sounds like your project may have some of the scripts from our audio spatializer SDK but not the plugin. See https://developer3.oculus.com/downloads/audio/1.0.4/Oculus_Audio_SDK_Plugins.
  • ivan.santiago.hgivan.santiago.hg Posts: 10
    NerveGear
    Thanks, I will take a look
  • ivan.santiago.hgivan.santiago.hg Posts: 10
    NerveGear
    I downloaded the last SDK and installed the packages LegacyOculusSpatializer and OculusNativeSpatializer, but it is still happening.
  • vrdavebvrdaveb Posts: 1,596 Oculus Staff
    Can you provide the full log from a run with the issue?
  • ivan.santiago.hgivan.santiago.hg Posts: 10
    NerveGear
    Since I installed LegacyOculusSpatialzier and OculusNativeSpatialzier, i am getting similar errors at launch, but the game runs without any problem.

    I get this log:

    09-09 15:22:13.561: E/Unity(14103): Unable to find libaudiopluginvrunity
    09-09 15:22:13.561: D/Unity(14103): Unable to lookup library path for 'libAudioPluginOculusSpatializer', native render plugin support disabled.
    09-09 15:22:13.561: E/Unity(14103): Unable to find libAudioPluginOculusSpatializer
    09-09 15:22:13.561: D/Unity(14103): PlayerInitEngineNoGraphics OK
    09-09 15:22:13.581: D/Unity(14103): [VRDevice] Successfully created device oculus.
    09-09 15:22:13.651: D/Unity(14103): GfxDevice: creating device client; threaded=1
    09-09 15:22:13.651: D/Unity(14103): [EGL] Request: ES 2.0 RGB16 565 0/0
    09-09 15:22:13.651: D/Unity(14103): [EGL] Found: ID[5] ES 2.0 RGB16 565 0/0
    09-09 15:22:13.661: D/Unity(14103): ANativeWindow: (2560/1440) RequestedResolution: (0/0) EGLSurface: (2560/1440)
    09-09 15:22:13.671: D/Unity(14103): Renderer: Mali-T760
    09-09 15:22:13.671: D/Unity(14103): Vendor:   ARM
    09-09 15:22:13.671: D/Unity(14103): Version:  OpenGL ES 3.1 v1.r7p0-03rel0.b596bd02e7d0169c10574b57180c8b57
    09-09 15:22:13.671: D/Unity(14103): GLES:     3
    09-09 15:22:13.671: D/Unity(14103): GL_EXT_debug_marker GL_ARM_rgba8 GL_ARM_mali_shader_binary GL_OES_depth24 GL_OES_depth_texture GL_OES_depth_texture_cube_map GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_EXT_read_format_bgra GL_OES_compressed_paletted_texture GL_OES_compressed_ETC1_RGB8_texture GL_OES_standard_derivatives GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_sync GL_OES_texture_npot GL_OES_vertex_half_float GL_OES_required_internalformat GL_OES_vertex_array_object GL_OES_mapbuffer GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_type_2_10_10_10_REV GL_OES_fbo_render_mipmap GL_OES_element_index_uint GL_EXT_shadow_samplers GL_OES_texture_compression_astc GL_KHR_texture_compression_astc_ldr GL_KHR_texture_compression_astc_hdr GL_KHR_debug GL_EXT_occlusion_query_boolean GL_EXT_disjoint_timer_query GL_EXT_blend_minmax GL_EXT_discard_framebuffer GL_OES_get_program_binary GL_OES_texture_3D GL_EXT_texture_storage GL_EXT_multisampled_render_to_texture GL_OES_surfaceless_context GL_OES_texture_stencil8 GL_EXT_shader
    09-09 15:22:13.671: D/Unity(14103): _pixel_local_storage GL_ARM_shader_framebuffer_fetch GL_ARM_shader_framebuffer_fetch_depth_stencil GL_ARM_mali_program_binary GL_EXT_sRGB GL_EXT_sRGB_write_control GL_EXT_texture_sRGB_decode GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent GL_OES_texture_storage_multisample_2d_array GL_OES_shader_image_atomic GL_EXT_robustness GL_EXT_draw_buffers_indexed GL_OES_draw_buffers_indexed GL_EXT_texture_border_clamp GL_OES_texture_border_clamp GL_EXT_texture_cube_map_array GL_OES_texture_cube_map_array GL_OES_sample_variables GL_OES_sample_shading GL_OES_shader_multisample_interpolation GL_EXT_shader_io_blocks GL_OES_shader_io_blocks GL_EXT_tessellation_shader GL_OES_tessellation_shader GL_EXT_primitive_bounding_box GL_OES_primitive_bounding_box GL_EXT_geometry_shader GL_OES_geometry_shader GL_ANDROID_extension_pack_es31a GL_EXT_gpu_shader5 GL_OES_gpu_shader5 GL_EXT_texture_buffer GL_OES_texture_buffer GL_EXT_copy_image GL_OES_copy_image GL_EXT_color_buffer_half_float GL_EXT_color_buffer_float
    09-09 15:22:13.671: D/Unity(14103):  GL_OVR_multiview GL_OVR_multiview2 GL_OVR_multiview_multisampled_render_to_texture 



    As I say, everything goes fine until I unmount the device, and mount it again. Then I get this:

    09-09 15:23:45.741: I/E:\tw\d45da6eca52cc600\Software\OculusSDK\Integrations\Unity\Releases\si-1(14103): Just mounted
    09-09 15:23:51.791: E/Unity(14348): Unable to find libAudioPluginOculusSpatializer
    09-09 15:23:51.811: I/E:\tw\39605cc0032fbe77\Software\OculusSDK\Integrations\Unity\Releases\si-1(14348): JNI_OnLoad
    09-09 15:23:51.881: D/Unity(14348):  GL_EXT_debug_marker GL_ARM_rgba8 GL_ARM_mali_shader_binary GL_OES_depth24 GL_OES_depth_texture GL_OES_depth_texture_cube_map GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_EXT_read_format_bgra GL_OES_compressed_paletted_texture GL_OES_compressed_ETC1_RGB8_texture GL_OES_standard_derivatives GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_sync GL_OES_texture_npot GL_OES_vertex_half_float GL_OES_required_internalformat GL_OES_vertex_array_object GL_OES_mapbuffer GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_type_2_10_10_10_REV GL_OES_fbo_render_mipmap GL_OES_element_index_uint GL_EXT_shadow_samplers GL_OES_texture_compression_astc GL_KHR_texture_compression_astc_ldr GL_KHR_texture_compression_astc_hdr GL_KHR_debug GL_EXT_occlusion_query_boolean GL_EXT_disjoint_timer_query GL_EXT_blend_minmax GL_EXT_discard_framebuffer GL_OES_get_program_binary GL_OES_texture_3D GL_EXT_texture_storage GL_EXT_multisampled_render_to_texture GL_OES_surfaceless_context GL_OES_texture_stencil8 GL_EXT_shade
    09-09 15:23:51.881: D/Unity(14348): r_pixel_local_storage GL_ARM_shader_framebuffer_fetch GL_ARM_shader_framebuffer_fetch_depth_stencil GL_ARM_mali_program_binary GL_EXT_sRGB GL_EXT_sRGB_write_control GL_EXT_texture_sRGB_decode GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent GL_OES_texture_storage_multisample_2d_array GL_OES_shader_image_atomic GL_EXT_robustness GL_EXT_draw_buffers_indexed GL_OES_draw_buffers_indexed GL_EXT_texture_border_clamp GL_OES_texture_border_clamp GL_EXT_texture_cube_map_array GL_OES_texture_cube_map_array GL_OES_sample_variables GL_OES_sample_shading GL_OES_shader_multisample_interpolation GL_EXT_shader_io_blocks GL_OES_shader_io_blocks GL_EXT_tessellation_shader GL_OES_tessellation_shader GL_EXT_primitive_bounding_box GL_OES_primitive_bounding_box GL_EXT_geometry_shader GL_OES_geometry_shader GL_ANDROID_extension_pack_es31a GL_EXT_gpu_shader5 GL_OES_gpu_shader5 GL_EXT_texture_buffer GL_OES_texture_buffer GL_EXT_copy_image GL_OES_copy_image GL_EXT_color_buffer_half_float GL_EXT_color_buffer_floa
    09-09 15:23:51.881: D/Unity(14348): t GL_OVR_multiview GL_OVR_multiview2 GL_OVR_multiview_multisampled_render_to_texture



  • petergiokarispetergiokaris Posts: 170 Oculus Staff
    Hi Ivan,

    Unity started supporting supporting the Oculus plug-in natively within Unity starting with v5.4 This means that you don't have to install our plug-in into your project for basic spatialization (you will see the OculusSpatailizer as a drop-down already there with a fresh install of Unity 5.4).

    In order to use the advanced features of the spatializer, such as room reflections, and setting near/far falloff values on AudioSource components, you will need to install our spatializer. This will unlock those features.

    5.3.6p4 may have had some of the native Unity functionality implemented, but it was not complete at that time. Because of this, you may be experiencing issues related to that. I would recommend that you upgrade to the latest Unity (v5.4.1) and remove our oculus spatializer integration from your project. Then try the oculus spatializer built into Unity and see if that resolves your issues. If it does, and you require the advanced features from above, re-install our developer spatializer to unlock them and see if everything is working.

    Let us know how this goes for you!

    Peter Giokaris
    Senior Software Engineer
  • ivan.santiago.hgivan.santiago.hg Posts: 10
    NerveGear
    Ok, problem solved.

    I was trying to avoid updating to 5.4 since we are about to release the game and this sudden changes of version usually brings problems, so, as you suggested, I removed the Oculus Audio SDK installed files. After that, I downloaded the last Unity Oculus Utilities version.

    I had not downloaded that  before because in the release notes it was especified that there could be problems with Unity 5.3.6 related to the Neck Model, but I just gave it a try and everything works fine now.

    Thanks both of you for your answer, is good to know that there is someone in the other side willing to help us :)

Sign In or Register to comment.