Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Empty third sensor position with OVRManager.tracker.GetPose(2)

neozerooneozeroo Posts: 29
Brain Burst
edited November 2016 in Unity Development
TL;DL: With 3 sensors, OVRManager.tracker.GetPose(id) works OK for the first and second sensors (ids 0 and 1), but returns (0,0,0) for the third sensor (id 2).

Hello!
I'm working on an app that uses each sensor position, and it works correctly for the two first trackers, but not for the third one.

  • OVRManager.tracker.count does return 3.
  • OVRManager.tracker.GetPresent(id) does return true to ids 0, 1 and 2 (and false to id 3, as there's only 3 connected sensors).
  • OVRManager.tracker.GetPoseValid(id) does return true to ids 0, 1 and 2 (and false to id 3).

  • OVRManager.tracker.GetPose(id) returns valid positions and orientations to ids 0 and 1, but empty values for ids 2 and 3 (it should return valid values for id 2).

"Empty values" being position (0, 0, 0) and rotation (0, 180, 0).

Here is an output example:

trackers count: 3
------
id: 0 | present: True | poseValid: True
id: 0 | position: (0.9854, 1.8364, 0.5153)
id: 0 | rotation: (15.8191, 233.1839, 1.3493)
------
id: 1 | present: True | poseValid: True
id: 1 | position: (-1.7348, 1.6925, -1.0900)
id: 1 | rotation: (359.7148, 67.5559, 0.3881)
------
id: 2 | present: True | poseValid: True
id: 2 | position: (0.0000, 0.0000, 0.0000)
id: 2 | rotation: (0.0000, 180.0000, 0.0000)
------
id: 3 | present: False | poseValid: False
id: 3 | position: (0.0000, 0.0000, 0.0000)
id: 3 | rotation: (0.0000, 180.0000, 0.0000)

Is this a bug, or am I doing something wrong?

Thank you.

Tagged:

Comments

  • vrdavebvrdaveb Posts: 1,596 Oculus Staff
    Third-sensor support has been added to the 1.10 release of the Utilities and the latest releases of Unity.
  • neozerooneozeroo Posts: 29
    Brain Burst
    vrdaveb said:
    Third-sensor support has been added to the 1.10 release of the Utilities and the latest releases of Unity.
    I'm actually using Oculus Utilities 1.10, but Unity 5.4.2p4. I see they have a 5.4.3 version.

    Whoa, they just released Unity 5.5 a few hours ago. I should've waited just a little more. Thanks!
  • vrdavebvrdaveb Posts: 1,596 Oculus Staff
    The version with the fix is 5.4.3p1. 5.5.0 should also have the fix.
  • neozerooneozeroo Posts: 29
    Brain Burst
    Awesome, thank you.
Sign In or Register to comment.