New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Is there a way to disable the Rift's auto turn off feature?

spaghettiboispaghettiboi Posts: 3
NerveGear
I'm looking to build an installation with just the Touch controllers and not use the Rift. But the thing is, the Touch controllers only track in 3D space when the Rift is on, but when you set the Rift down on a table it'll automatically turn off unless you pick it up and move it. How can we turn off this auto off feature?

Comments

  • imperativityimperativity Posts: 1,604 Oculus Staff
    Hi,

    I am currently looking into this and will advise you on what information I find that is applicable to your situation.
  • spaghettiboispaghettiboi Posts: 3
    NerveGear
    Hi,

    I am currently looking into this and will advise you on what information I find that is applicable to your situation.
    Any update on this?
  • imperativityimperativity Posts: 1,604 Oculus Staff
    @spaghettiboi

    By triggering the proximity sensor manually on the rift you can convince the unit it is being worn and it will not turn off. I have no method of demonstrating this and we do not offer official support in usage scenarios outside of the intended use cases for Rift. 

    There is no software method or ability to turn off the auto off feature, however.
  • ConstellationConstellation Posts: 191
    Art3mis
    I'd really like an API call to temporarily disable the sensor; while doing Touch development I often need to use the mouse, keyboard or touch controllers while looking at Visual Studio or the Unity editor.
  • imperativityimperativity Posts: 1,604 Oculus Staff
    @Constellation

    Sorry, but no API call exists for that. I understand your use case necessitates this---thus the work around mentioned above.
  • ConstellationConstellation Posts: 191
    Art3mis
    I was looking for solutions on reddit and came across this post which among some physical solutions also featured a software solution! Go to the Oculus Debug Tool in C:\Program Files\Oculus\Support\oculus-diagnostics and enable the "Bypass Proximity Sensor Check" setting. This works great for me with the 1.18 runtime. It makes the Touch development and debugging I'm working on way way easier!


Sign In or Register to comment.