My Unity scene in the Gear VR is VERY choppy/laggy — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

My Unity scene in the Gear VR is VERY choppy/laggy

Now I read that the you should have 50k – 100k polygons per frame (I guess thats the whole scene made up of between 50k-100k faces. I am creating a small Garden, using only meshes, no images, planes or anything, the flowers and grass are all made up of faces, but as low poly as I can get them. In total so far my scene has 20k faces. 

When I build it in Unity, and watch it through the Gear VR and look at the Garden, the scene is choppy/laggy. But when I look behind, where its just the wall and a few chairs, its completely fine. Am I doing something wrong? Is there a way to fix this as this is my 3rd year final year project I am working on, and if I cannot fix this lag (whilst also needing to add more to the Garden), the whole point/aim of my project will be for nothing! ) :( hopefully someone can shed some light on this issue. 

Comments

  • CostaP1CostaP1 Posts: 11
    NerveGear
    So I did some research as well as using your information about how to stop the lagg/shakyness of my Unity scene in the Gear VR. These were the steps I tried:

    -Set my light and models to Static as they were not going to move. In the 3D Software, I actually combined all my models to 1 mesh as well. 
    -Tried out LOD (level of detail). My scene was not that big/big enough for this feature to work
    -Materials, all my models/mesh are part of 1 lambert material, as I have used vertex painting, so only 1 material is applied.

    After all this testing and building it was still blurry so none of these things worked. I also changed the quality of the shadows. I then decided to remove shadows to see what my scene would look like without them, and voila, the choppy/laggy/jittering (if thats a word) scene stopped! I could look smoothly around.

    However....I would like shadows in my scene nonetheless. I tried a suggestion from imperativity about using blob shadows, but the effects are not good. This image below shows that the blog shadows do not display the plants shadow from underrneath, and when I increase its size, my whole scene (the Garden), becomes darker. Its not pitch black, but its darker, as if the whole scene is covered with 1 shadow. The image underneath the blob shadows shows what shadows are created in Unity from the directional light, still blurry in the Gear VR as with

    Edit: imperativity told me to change my Directional Light Baking option in the inspector, from 'Realtime' to 'Baking'. This still caused lag. Some research online allowed me to find out to change it to 'Mixed' instead (I also chose the lowest shadow quality and built it, and it worked in Gear VR! There are shadows but of very low quality. At the moment/probably tommorow, I am working/testing the quality of the shadows with the 'Mixed' lighting. I will give an update on here!





  • CostaP1CostaP1 Posts: 11
    NerveGear
    edited February 2017
    Ok thanks!

    I wrote a paragraph (which somehow dissappeared, or had to be confirmed by an admin to post), outlining what methods I had tried to reduce the lag, e.g LOD (level of detail, shadoq quality, static meshes and lighting etc, but none of those worked.

     I then found out by removing shadows completely, the choppy/lagg stopped. But the problem was that I needed shadows, so imperativity advised that I turn my light to 'baked'. That removed the shadows from the scene for some strange reason. So some research online allowed me to find the solution of changing lighting to 'mixed', that way I can have shadows and no lag. I am still testing the shadow quality in my scene so its nice and critsp, not rough shadows!
  • CostaP1CostaP1 Posts: 11
    NerveGear
    So I did some research as well as using your information about how to stop the lagg/shakyness of my Unity scene in the Gear VR. These were the steps I tried:

    -Set my light and models to Static as they were not going to move. In the 3D Software, I actually combined all my models to 1 mesh as well. 
    -Tried out LOD (level of detail). My scene was not that big/big enough for this feature to work
    -Materials, all my models/mesh are part of 1 lambert material, as I have used vertex painting, so only 1 material is applied.

    After all this testing and building it was still blurry so none of these things worked. I also changed the quality of the shadows. I then decided to remove shadows to see what my scene would look like without them, and voila, the choppy/laggy/jittering (if thats a word) scene stopped! I could look smoothly around.

    However....I would like shadows in my scene nonetheless. I tried a suggestion from imperativity about using blob shadows, but the effects are not good. This image below shows that the blog shadows do not display the plants shadow from underrneath, and when I increase its size, my whole scene (the Garden), becomes darker. Its not pitch black, but its darker, as if the whole scene is covered with 1 shadow.

    The image underneath the blob shadows shows what shadows are created in Unity from the directional light, still blurry in the Gear VR as within Unity. Is there some fix where I can have shadows displaying, without the lag? I have found it to be the shadows causing it, but I need some sort of fix

    Any help would be appreciated!





Sign In or Register to comment.