Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Getting play area dimensions in Unity 5.4.0 not working

CriteriumCriterium Posts: 10
NerveGear
Calling 
OVRManager.boundary.GetDimensions(OVRBoundary.BoundaryType.PlayArea) 
or 
OVRManager.boundary.GetDimensions(OVRBoundary.BoundaryType.OuterBoundary)
in Unity 5.4.0 always just returns a zero vector. OVRManager.boundary.GetConfigured() also returns false.

We've tried this on multiple machines with the same result.
This seems to have been fixed with later versions of Unity, we tried both 5.4.3 and 5.5.0 with success.

Is there a workaround or some other way to get play area size in Unity 5.4.0?

Steps to reproduce issue:
- Create empty project in Unity 5.4.0f3
- Import Oculus utilites (tried on both 1.10.0 and 1.11.0)
- Set up scene with OVRCameraRig, enable Virtual Reality support in Unity, etc.
- Call OVRManager.boundary.GetDimensions in some script

Comments

  • CriteriumCriterium Posts: 10
    NerveGear
    Ok. Thanks for the answer!
  • AdamHazonAdamHazon Posts: 2
    NerveGear
    I have the same problem.. always zero and GetConfigured always false.
    Can't find any solution online, I'm spending days on it, PLEASE HELP!
  • Henrik96Henrik96 Posts: 1
    NerveGear
    Same problem. Tried it with many Versions using the Oculus Quest via link Cable.
    I want to Calibrate Player Position and Rotation via Guardian system to get consistent positioning in Unity.
  • MVRKDEVMVRKDEV Posts: 13
    NerveGear
    Have you guys managed to solve this issue?
  • SharpeGameSharpeGame Posts: 3
    NerveGear
    edited January 9
    Have you added a GuardianBoundaryEnforcer to the scene? That was my problem when trying to get the dimensions but would always get zero.
  • MVRKDEVMVRKDEV Posts: 13
    NerveGear
    Yeah, I'm using the GuardianBoundarySystem scene to test between the link cable and the actual build. It recognizes the guardian system when I build to the Quest, but when I use the link cable and run in the editor, it doesn't recognize it. 
  • SoakingRichSoakingRich Posts: 5
    NerveGear
    im having the same problem with this, despite it seeming to work fine about 4 months ago. Can no longer correct boundary data from Rift S in Unity 2019.2.8 .     GuardianBoundarySystem scene doesnt show a configured boundary :(
Sign In or Register to comment.