Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

[Gear VR] Performance drops when activating particle system - why?

motorsepmotorsep Posts: 1,420 Oculus Start Member


When I activate particle system on the rising drone (using Activate node), performance drops momentarily. Do you happen to know why is this happening and how to work around it ?

Thanks

Comments

  • Leemon89Leemon89 Posts: 29
    Brain Burst
    Hey! I'm experiencing similar issue with pulse particles like muzzle flash, weapon shells, bullet hits. I believe the start of simulation is a performance-heavy process by itself, but I'd like to see more info on this if possible. Cheers!
  • aussieburgerVRaussieburgerVR Posts: 220 Oculus Start Member
    edited April 2017
    Do you guys only see it the very first time you spawn the emitter? and afterwards when activating the same emitter again there is no problem?
    I had this problem and workaround it by spawning my emitters in the background behind a intro screen and then destroying them straight afterwards - with nothing else going on there was no performance drop and not noticeable on a black screen with the game text anyway :D Then later when using them in the game there was no performance drop
  • motorsepmotorsep Posts: 1,420 Oculus Start Member
    I only spawn that emitter one time. Thanks for the tip - I'll try your method. I am actually thinking not to destroy it, but rather reset it when I need to show it.

    Actually now that I am thinking about it, I spawn it hidden, and then reveal it. So the hiccup happens on reveal, not on spawn.
  • aussieburgerVRaussieburgerVR Posts: 220 Oculus Start Member
    hmmm ok must be something else for you
  • drashdrash Posts: 2,846
    Neo
    Some of my biggest frame drops have been due to uploading a shader to the GPU for the first time.  

    My favorite solution to that is helpfully provided by Unity in Edit -> Project Settings -> Graphics, in the Shader Preloading section.   Hit the Clear button, run through your app in the editor making sure to look at everything that can be looked at, and then stop playing.   The Shader Preloading section should show a # of shaders that it has tracked during gameplay, and you can save this list out to an asset using the "Save to asset" button there.   Then, you want to make a script that references this asset, and calls WarmUp() on it when your app starts.   All shaders that are used during your app are now on the GPU ready to go as soon as they are needed.

    Of course, there are other factors, like uploading textures to GPU, loading resources from disk/APK for the first time, etc, but I found this shader preloading tip to be extremely useful.   You should be able to pinpoint what's causing the spike if you use the Profiler w/ Deep Profile turned on.
  • motorsepmotorsep Posts: 1,420 Oculus Start Member
    @drash
    I am not sure if UE4 has the same kind of deal.
  • drashdrash Posts: 2,846
    Neo
    edited April 2017
    motorsep said:
    @drash
    I am not sure if UE4 has the same kind of deal.
    Woops my bad, assumed you were using Unity!
  • Mohammed_hashimMohammed_hashim Posts: 90 Oculus Start Member
    motorsep did you able to find a workaround for this issue?

  • motorsepmotorsep Posts: 1,420 Oculus Start Member
    motorsep did you able to find a workaround for this issue?

    I don't develop for Gear VR any longer and I haven't tried particles on Go yet.
  • Mohammed_hashimMohammed_hashim Posts: 90 Oculus Start Member
    motorsep said:
    motorsep did you able to find a workaround for this issue?

    I don't develop for Gear VR any longer and I haven't tried particles on Go yet.
    I see, based on my experience for the last week its really not fun to develop for GearVR with UE4 since the performance is very low and you cant do much about it. anyway good luck with your project.
  • motorsepmotorsep Posts: 1,420 Oculus Start Member
    motorsep said:
    motorsep did you able to find a workaround for this issue?

    I don't develop for Gear VR any longer and I haven't tried particles on Go yet.
    I see, based on my experience for the last week its really not fun to develop for GearVR with UE4 since the performance is very low and you cant do much about it. anyway good luck with your project.
    I don't think it's UE4's fault. Oculus Go and UE 4.21.1 work fine. However, if you are trying to shove high-end effects (especially post-processing) into Gear VR, it won't work simply because none of the smartphones is designed to run high-end VR (even though it could be mobile high-end).
  • Mohammed_hashimMohammed_hashim Posts: 90 Oculus Start Member
    motorsep Based on my research seems UE4 have issue with post process on android with empty level and it runs fine with IOS with normal game, so yeah i think UE4 have problem with android HDR like other dev mentioned even with flat games. I'm downloading old UE to see if what other devs said true or not since some devs mentioned this problem appeared after 4.10. regarding heavy lose on FPS when HDR enabled even when you disable all post process on your game. 
Sign In or Register to comment.