New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

[Unity] [Cloud storage] Platform.CloudStorage.Save() error OVR80328285


I tried to do cloud save on a standalone build (not Unity's play mode).
And I always got an error OVR80328285 when called  CloudStorage.Save("SaveData", "Save", System.Text.Encoding.UTF8.GetBytes(data), data.Length, string.Empty) after doing Core.AsyncInitialize() and Entitlements.IsUserEntitledToApplication()

I saw the error message in C:\Users\$USERNAME\AppData\Local\Oculus\Service_xxx.txt but I got no idea what happend.

14/06 08:15:25.966 {!ERROR!} [OAF ERROR] ..\..\..\package\PackageManager.cpp(210) : Package does not exist: 1066517180114723 (1971015)
14/06 08:15:25.967 {!ERROR!} [OAF ERROR] ..\..\..\PlatformPlugin\PlatformPluginManager.cpp(821) : request_path_cb failed (1971005)
14/06 08:15:25.967 {!ERROR!} [IpcRouter] Command /platform_plugin/cloud_storage/request_path caused an error: OVR80328285

Relative discussion

Unity 5.4.5f1
Platform SDK v1.15.0



  • imperativityimperativity Posts: 1,711 Oculus Staff

    Welcome to the Oculus Developer Forums.

    Your version of Unity may be incompatible with this version of Platform SDK. If you were to try the latest version of Unity, does this problem still occur?
  • danielchenplayeriumdanielchenplayerium Posts: 4

    Thanks for you help, I've tested it on Unity version 5.6 and got the same error, so I think it's not related with Unity version. So I tried on other things and finally worked successfully.

    There are some points:
    1. Upload a build to channel and download it. (the app is in installed tab in Oculus Client)

    And then you can test Cloud Storage anywhere (Unity editor, standalone build or execute app in Oculus Client).

    2. The problem I faced is app always shows "Not Valid" in Oculus Client. But no matter what I did, I restarted Oculus Client, restarted computer or logged out and logged in, they were no used. 

    At the end I found a "Restart Oculus" in the Oculus Client setting.
     After I clicked it, the app could be download and install.

    Relative discussion:
Sign In or Register to comment.