New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Why does my gameObject's mesh edges were flickering in Oculus?

NirmlRjNirmlRj Posts: 13
NerveGear
Hello Guys, I am making a quite big world for my game in Unity for Oculus Rift. Initially when I tried my game with default settings it looked somewhat blurry and mesh edges were flickering like a hell (especially trees). So I changed RenderScale value to 2 from 1. It made huge difference in my game quality but FPS went below 60 and then I adjusted RenderScale value to 1.2 so now my game quality is okay and FPS is also okay. But the problem I'm facing now is the flickering in mesh edges. I even tried with 8x MSAA but still flickering exists. Does anyone know how to solve this. FYI : THOSE FLICKERING PROBLEM IS ONLY IN OCULUS SCREEN, PC MONITOR DOES NOT SHOW THAT MUCH FLICKERING

Oculus Version : Oculus Rift CV1

Current Settings :  Rendering Path -> Forward,  AA -> 8x MSAA, VSync -> Disabled, Color Space -> Gamma, Stereo Rendering Method -> Single Pass. 

PC Specs : RAM -> 32GB, Processor -> Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz 4.00 GHz,  Gfx -> NVIDIA GeForce GTX 1070

If you guys need additional Info, I will provide :smile:
 

Answers

  • moonbearmoonbear Posts: 36
    Brain Burst
    Does your camera also have "Forward" as the rendering path? Sometimes it might override "Player Settings".
  • NirmlRjNirmlRj Posts: 13
    NerveGear
    moonbear said:
    Does your camera also have "Forward" as the rendering path? Sometimes it might override "Player Settings".
    Yes. I always check it before playing game in editor and before taking build.
  • MohamedElmazenMohamedElmazen Posts: 11
    NerveGear
    if you still have this flickering 
    Add this script to any Game Object

    public class SetAntiAliasing : MonoBehaviour
    {
        public int antiAliasing = 2;
        // Use this for initialization
        void Start ()
        {
            QualitySettings.antiAliasing = antiAliasing;
        }
    }

    Anti-aliasing from the script will override the quality settings in gameplay.

    hope it help.
  • NirmlRjNirmlRj Posts: 13
    NerveGear
    if you still have this flickering 
    Add this script to any Game Object

    public class SetAntiAliasing : MonoBehaviour
    {
        public int antiAliasing = 2;
        // Use this for initialization
        void Start ()
        {
            QualitySettings.antiAliasing = antiAliasing;
        }
    }

    Anti-aliasing from the script will override the quality settings in gameplay.

    hope it help.
    MSAA is already enabled in Quality Settings(8X MSAA). Does it really make difference to add it through script? Just asking. 
  • MohamedElmazenMohamedElmazen Posts: 11
    NerveGear
    yes you have to override it especially for VR development.
  • carsten.knoblichcarsten.knoblich Posts: 5
    NerveGear
    yes you have to override it especially for VR development.
    I’m just curious, is this a bug or somehow strangely intended?
  • MohamedElmazenMohamedElmazen Posts: 11
    NerveGear
    I think its not bug , its an performance optimization from unity side.

    From Unity Documentations 
    Anti-aliasing value indicates the number of samples per pixel. If unsupported by the hardware or rendering API, the greatest supported number of samples less than the indicated number is used.


  • A1_MandeepA1_Mandeep Posts: 10
    NerveGear
    @carsten.knoblich
    Were you able to solve your problem. If yes, then kindly tell me the solution as I am having the same issue.
  • NirmlRjNirmlRj Posts: 13
    NerveGear
    @A1_Mandeep
    Enabling anti aliasing in runtime had almost no effect in 5.4.0. But when I switched to 2017.2.0 unity version I was no longer needed to enable it in runtime. Even @imperativity
     told me to try 5.6.0 or above versions. Try new version.
Sign In or Register to comment.