Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

My GearVR app hangs at the splash screen unless I delete from my phone before doing a build and run

The title says it all really. Here is my process
1. Build and run app from unity - works fine
2. Make an change in Unity
3. Build and run - App opens, splash screen displays then the app hangs with a grey screen
4. Delete the app from my phone
5. Build and run (no changes in unity this time) - App works fine again

??? I'm new to GearVR development (not new to unity in general) and this is confusing me.

Device: Samsung Galaxy S6
Unity Version: 2017.10f3 (also tried 5.6.0f3 with same results)

Any ideas??

Comments

  • delphinius81delphinius81 Posts: 297
    Nexus 6
    Does it say anything in the the logcat logs?
  • adrian.taylor.3975adrian.taylor.3975 Posts: 2
    NerveGear
    Yeah there is a message about an unrecognized app id (I have set the osig file and the bundle identifier). I've even uploaded to the oculus store as an alpha test and tried it via oculus home. But I get the same thing.

    As far as I can tell, this is completely random. I have tried to delete everything from my scene and load things in one by one and build... But what appears to work one time, will not work the next time?

    This leaves me extremely confused and frustrated.

    any suggestions? Is there somewhere I can reach out for official help from Oculus or Unity? I'm happy to upload a project. But I'd need it to remain confidential if possible.
Sign In or Register to comment.