New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

The Windows SDK version 10.0.10586.0 was not found

brlibrli Posts: 1
I was following the PC SDK getting started guide, and progressed relatively smoothly until I tried to run the demos in the samples file Samples/Projects/Windows/VS2015/Samples.sln in Visual studio 2015.

I encountered the error "The windows sdk version 10.0.10586.0 was not found." I followed the steps to correct it in the guide as well: I followed the instructions: edit Project Properties → General → Target Platform Version and changed the version to 10.0.15063.0, which was the windows 10 SDK on my computer.

However, with this, the same exact error remained, "The windows sdk version 10.0.10586.0 was not found." So I went even farther, going into the Windows10SDKPaths.props file, and changed all 6 instances of 10.0.10586 to 10.0.15063. However, the same exact error popped up once again. I've tried closing Visual studio and restarting my laptop between steps, however, the result is still the same.

Can you please advise on how to fix this? Thanks in advance.


  • imperativityimperativity Posts: 1,697 Oculus Staff

    Welcome to the Oculus Developer Forums.

    I was able to successfully run the 1.16 PC SDK Samples.sln in VS2015.

    I was also able to build the solution with both 8.1 and 10.0.15063.0 target platforms successfully as well.

    If you were to reinstall VS2015 and the windows SDK again, does this problem persist? If so, does this problem continue if you were to use another computer?

    Please advise.
  • neilsarkarneilsarkar Posts: 4
    I also had this identical issue with the VS2017 community edition that is installed automatically when you install the oculus SDK.

    Just uninstalled VS2017, I'm downloading VS2015 update 3 from Studio 2015 with Update 3 and will let you know if I can still reproduce this issue.
  • ConstellationConstellation Posts: 194
    When I switched the target platform with VS 2017 Community it didn't change all the version strings in my .vcxproj file. I closed VS, edited the file manually and then I was able to get it to build.
  • neilsarkarneilsarkar Posts: 4
    Ok yeah so it works now. If someone else runs into this issue, here are the steps I took to fix it:

    1. Add/remove programs -> click "Modify" on Visual Studio 2017, then "Uninstall"
    2. Add/remove programs -> Uninstall anything matching "visual studio" or "windows sdk"
    3. Download visual studio 2015 from Studio 2015 with Update 3 (you may need to add access to the free visual studio dev toolkit, but you don't need to pay for a VS subscription)
    4. On the VS2015 installer, check "Windows and Web Development" => "Universal Windows App Development Tools"
    5. Delete sdk folder to remove previous VS files
    6. Unzip sdk again and open solution
    7. Right click solution => Retarget solution
    8. Build
  • LeskonioLeskonio Posts: 1
    I had the same problem, and neilsarkar's steps worked for me. I think the SDK guide could use an update to make this more clear...
  • zhtetzhtet Posts: 11
    edited December 6
    Has anyone still encounter this problem in SDK 1.20? I am trying to compile OculusRoomTiny(DX12). I've retargeted everything to 10.0.14393.0 (what I have locally) and only that project is not compiling; everything compiles fine. And that's the one project I was hoping to play around with :(
    The same project works fine with an older sdk download I have locally (1.3).
  • ConstellationConstellation Posts: 194
    Try manually editing the project file as I suggested in my earlier post.
  • zhtetzhtet Posts: 11
    Doh, just saw that. I was reading neilsarkar's post and missed yours. Thanks!
Sign In or Register to comment.