Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

The app doesn't pause when opening the Universal Menu

StudioTrapcardStudioTrapcard Posts: 2
NerveGear
edited September 2017 in Store Submissions
I've recently submitted an app for review then recieved that error message.
However i've tested reserved interaction and it worked as expected.
What should i do then? i could not proceed because of this.

This is a message i've recieved
The universal menu integration in your functioning as expected. The intended behaviors include: 1) pressing Oculus Home button should bring up Universal Menu, 2) pressing the Oculus Home button again should return to the app experience, 3) re-orientation within Universal Menu should reorient users in the app experience and 4) exit to home should bring up a prompt that warns user that he/she is exiting the experience. The app doesn't pause when opening the Universal Menu

Comments

  • StudioTrapcardStudioTrapcard Posts: 2
    NerveGear
    edited September 2017
    Hi! i've found the game is muted but not paused. I use UE4 for my game, is there same option for this engine too?
  • rfunk82rfunk82 Posts: 10
    NerveGear
    edited November 2017
    "If you are using Unity, "uncheck" the run in background checkbox in Unity to solve this issue with the game not pausing."

    I'm using unity and this didn't fix it for me.
  • ZikokoZikoko Posts: 0
    NerveGear
    Hello

    Still having this issue. Game not pausnig when entering universal menu. Using UE4.
  • ZikokoZikoko Posts: 0
    NerveGear
    Hello

    Still having this issue. Game not pausnig when entering universal menu. Using UE4.
  • fariazzfariazz Posts: 80 Oculus Start Member
    Did anyone figure out how to pause the game when going to the universal menu in Unity?
    Virtual Reality Mini-Degree - Learn to code in Unity and build 15 VR games and experiences
  • fariazzfariazz Posts: 80 Oculus Start Member
    Actually unchecking the run in the background option in the player settings did it for me.
    Virtual Reality Mini-Degree - Learn to code in Unity and build 15 VR games and experiences
  • gritourbano1gritourbano1 Posts: 5
    NerveGear
    El mismo problema por acá.  Usando Unity
  • gritourbano1gritourbano1 Posts: 5
    NerveGear
    I already uncheck run in background but the problem persist.
  • mhenriemhenrie Posts: 1
    NerveGear
    I am also having issue with game not pausing with Universal Menu on Rift, building with Unity.  Works on Go but not Rift. I see no Universal Menu events to tie into and the "run in background' setting is not helping. 

    Any other ideas?

    Unity 2018.3.6 Oculus Integration 1.34
  • priyanka.kottepriyanka.kotte Posts: 3
    NerveGear
    I have uncheck the "run in background", still I am getting the issue.  Did anyone get the solution for this?

  • DemonGamesStudioDemonGamesStudio Posts: 25 Oculus Start Member
    Same issue here, not sure what to do. (Using Unity) Unchecking "Run in background" does not work for me. 
  • Schneider21Schneider21 Posts: 48
    Brain Burst
    My god, these forums aren't great for getting support on real issues, are they?  :/
  • DemonGamesStudioDemonGamesStudio Posts: 25 Oculus Start Member
    edited May 2019
    Ok, guys i hope this helps. This is how i fixed it. 

    (This is for Unity)

    Just for a bit of explanation. the hasInputFocus checks if the user is in the oculus menu and the hasVRFocus checks if the HMD is in use or not. Time.timeScale is the ingame time, this will stop time if set to 0, the audio listener will stop audio when set to false, and finally the player object is the Avatar attached to the player, this will dissable when the player is in menu or if the headset is off. 


Sign In or Register to comment.