Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Gear VR with 1.18.1 utilities constantly complains about plugin versions in 2017.1.1

flarbflarb Posts: 68
Hiro Protagonist
Im using the latest oculus unity utilities with 2017.1.1p2. I upgraded the plugin and deleted the old 1.14 plugin folder. But in the logcat, I constantly see this error:

ovrp_GetAppHasFocus only available in 1.18 and newer plugins

There’s a bunch of similar errors in the log. Is it possible unity is still building with 1.14?

I even deleted the library folder and reimported everything to no avail. 

Comments

  • yur0culusyur0culus Posts: 1
    NerveGear
    edited October 2017
    i still have the same issue where logcat gets spammed with warning logs; 
    Unity: ovrp_GetAppHasInputFocus only available on 1.18 and newer plugins 
     
    Unity: ovrp_GetAppHasSystemOverlayPresent only available on 1.18 and newer plugins ;

    I am using Unity 2017.1.1.p4; I have deleted 1.14 folder, updated to Oculus utilities 1.18.1, then in Unity Editor selected Tools/Oculus/Update Oculus Utilities plugin -> popup is shown "OVRPlugin is already up-to-date. Current version 1.18.1. Bundled version 1.14.1"...   
    So it seems that OVRPlugin is updated to 1.18.1 , but  somehow i still have these warning logs. Any suggestions?  Any other way to update to OVRPlugin 1.18.1?
Sign In or Register to comment.