Stereo off with Hmd motion on? — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Stereo off with Hmd motion on?

8bit8bit Posts: 94 Oculus Start Member
edited January 2014 in Unreal Development
Is there a way to have the Oculus head tracking on when stereo rendering is off?

I've tried this (and several other things) in the console to no avail:
stereo off
motion on

We are trying to capture some video footage of gameplay and would like to have the head tracking on but get nice full screen unwarped imagery.

Thanks.

Comments

  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Theoretically you can enable the stereo, disable the distortion, set double resolution and use one eye rectangle for the video recording.

    Use the following console commands:
    stereo on
    hmdwarp off
    setres 2560x800w
    
    Hope that helps.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • 8bit8bit Posts: 94 Oculus Start Member
    That's a start.
    It still has some gnarly warping around the edges though.

    I'm able to make a little better by change fov settings but still have a good amount of warping.
    I tried:
    stereo nofov
    
    and
    stereo fov fx=82 fy=90 a=1
    
    The latter gives me something better.

    Anyway, if you have any ideas about how to restore normal fov in stereo that'd be great.
    Thanks.
  • artyom17artyom17 Posts: 319 Oculus Staff
    I've added this feature request into TODO list.
Sign In or Register to comment.