Oculus Spatializer Plugin / FMOD Studio / Unreal / Not getting any sound — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Oculus Spatializer Plugin / FMOD Studio / Unreal / Not getting any sound

VRexVRex Posts: 64
Hiro Protagonist
edited November 2017 in Audio SDK Development
Howdy - I've installed the Oculus Spatializer to my FMOD Studio and it shows up fine in the program. I've dropped the Oculus Spatializer onto my event's master track. When I play events within FMOD, everything works/sounds fine. When I build and drop in an audio event in Unreal, I hear nothing. I've tried replacing the Oculus Spatializer with the FMOD 3D Panner and the sound works fine in Unreal.

I'm running Unreal 4.17.2, FMOD Studio 1.09.04, and Oculus Audio SDK 1.1.0. I'm on Windows 10.

I've tried setting the event to Mono, setting the FMOD project preferences under Build to be stereo output, and I've changed the FMOD preferences within Unreal to be stereo. Nothing has any effects so far. Any ideas of how to fix this? Thanks!

EDIT: I've checked to make sure Oculus Spatializer plugin is active within Unreal as well and it is. 

Jesse Kirberger

Comments

  • PetrozaPetroza Posts: 147 Oculus Staff
    Are you seeing any errors coming from FMOD? If you're heading nothing at all it sounds like there might have been an issue loading the bank. Given this is most likely an issue with the FMOD UE4 integration you'll probably get a better answer on the FMOD Q&A. It looks like you already posted there so I'll link it here in case anyone else runs into the same issue.

    http://www.fmod.org/questions/question/oculus-spatializer-plugin-fmod-studio-no-sound-output-in-unreal-1/
  • VRexVRex Posts: 64
    Hiro Protagonist
    Peter - no errors in FMOD. The only reason it seems like an Oculus Spatializer error is when I replace the plugin with the built-in 3D Panner in FMOD, I can hear sound just fine. Any ideas? Are there specific settings I have to set in FMOD to make it work? I haven't been able to find a very detailed guide on how to use the Spatializer plugin with FMOD. Thanks!
    Jesse Kirberger
  • PetrozaPetroza Posts: 147 Oculus Staff
    I agree with what Cameron said on the FMOD Q&A, it sounds like the plugin isn't loaded in UE4. You need to make sure the Oculus spatializer plugin is loaded correctly in UE4 (not just in the FMOD Studio Editor). The plugin is the DLL and the game (UE4) needs to know about it so that it can load the banks and play the sounds.
  • VRexVRex Posts: 64
    Hiro Protagonist
    Peter - Yes, adding the plugin into the project folder under Plugins/FMODStudio/Binaries/Platform as well as a text file named 'plugins.txt' with 'OculusSpatializerFMOD' as the contents did the trick. Thanks for your help.
    Jesse Kirberger
  • SMDVR_DevSMDVR_Dev Posts: 2
    NerveGear
    'Petroza said:
    I agree with what Cameron said on the FMOD Q&A, it sounds like the plugin isn't loaded in UE4. You need to make sure the Oculus spatializer plugin is loaded correctly in UE4 (not just in the FMOD Studio Editor). The plugin is the DLL and the game (UE4) needs to know about it so that it can load the banks and play the sounds.
    I'm experiencing the same issue that Jesse was a few months ago. I've downloaded the Oculus Spatializer FMOD 1.27.0, I've added the dll file to FMOD Studio as such 
    'D:\Program Files\FMOD Studio 1.10.07\plugins\OculusPlugins\OculusSpatializerFMOD.dll' and have added the fmodstudio file to the plugin file of UE4.
    As Jesse has mentioned above, he added the dll to the binaries as well as a the plugin.txt file, but I'm unable to locate said file in any of the fmod or oculus files I've downloaded.

    If either of you could lend some assistance in this matter I would greatly appreciate it.

    Thanks,
    Zach
  • SMDVR_DevSMDVR_Dev Posts: 2
    NerveGear
    I've found when going into the details of the events in UE4 that the FMOD spatializer is creating the event with the 3D parameter set to true:


    while the ones with the oculus spatializer are set to false:


    how can I rectify this?
  • PetrozaPetroza Posts: 147 Oculus Staff
    Sounds like you might be missing a few steps there. That path: 'D:\Program Files\FMOD Studio 1.10.07\plugins\OculusPlugins\OculusSpatializerFMOD.dll' doesn't look right to me. Is that working?

    Before trying to get the spatializer working, can you confirm that you have FMOD Studio integrated properly into your UE4 project and can play FMOD sounds in UE4? That would be the first step, from there you can add our plugin by following the instructions here: https://www.fmod.com/resources/documentation-api?page=content/generated/engine_ue4/plugins.html#/



Sign In or Register to comment.