How to pass VRC TestLaunchIntoVR — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

How to pass VRC TestLaunchIntoVR

When I used VRC toolto test the TestLaunchIntoVR for the app, I got the error "The application took too long to submit the first frame". The reference link page said that 
If your app takes longer than 4 seconds to launch, you must provide a head-tracked loading indicator. Head-tracked means the UI elements must remain stationary in space when the user turns their head. Do not lock any logos or progress indicators to the user’s face.

For my app, there is no UI element or other game object locking to the user's face at the first 15 secs, but the app can't pass the test. Can someone give an example for this to help me to understand it better? Thanks!

Comments

  • alejandro.marcualejandro.marcu Posts: 5
    NerveGear
    What's the status for this?
    I'm running into the same issue, so I tried doing the simplest app possible (just put a cube and configure to be VR), and it still doesn't pass the test.  
  • ahgamesahgames Posts: 2
    NerveGear
    Hi, I am also interested on the status. Having the same issue. 
    Oculus App and OculusVRCValidator version 1.23.0.

  • leon.moctezumaleon.moctezuma Posts: 8
    NerveGear
    Same issue here
  • leon.moctezumaleon.moctezuma Posts: 8
    NerveGear
    I created a basic scene without anything and I created a build with it. It takes 6.633232 seconds to send the first frame... is it even possible to achieve it with Unity?
  • leon.moctezumaleon.moctezuma Posts: 8
    NerveGear


    I previously tested in a production project with Unity 5.5.5

    The image belong to an empty project with the latest Unity 2017.3.1p1 and the time improved significantly it went 2 seconds but it still fails with the VRC Validator version 1.23.0.0

    There is no way that someone developing with Unity will pass ever the current test.
  • johnluxfordjohnluxford Posts: 13 Oculus Start Member
    I believe we're experiencing the same thing, using both Unity 2017.2.0p4 and 2017.3.1p1. I've turned everything off in our loader and it's still taking 4.6-5.5 seconds.
  • leon.moctezumaleon.moctezuma Posts: 8
    NerveGear

    Ok, support from Unity contacted me and gave me the solution, in Unity Pro you can totally disable the splash screen.
  • johnluxfordjohnluxford Posts: 13 Oculus Start Member
    Even with Unity Pro and Show Splash Screen disabled, Unity shows an app splash image before loading our loading scene for 4-5 seconds. That time didn't really go down when we stripped our loading scene down to almost nothing.
  • Heaney-555Heaney-555 Posts: 107
    Art3mis
    To be clear though, will actual store submissions encounter this issue?
  • wirelessxdreamerwirelessxdreamer Posts: 2 Oculus Start Member
    I'm experiencing the same thing here. about 5 seconds is the fastest load i've ever seen. I've failed that test every time so far.
  • MichealgomesMichealgomes Posts: 1
    NerveGear
    edited July 13

    I dont understand it. Whenever I see people asking about getting into VR, there's always some shill pushing the Vive, giving false information about the Rift, if they even mention it.

    So usually I chime in, pointing out that they are literally equals in quality (except for a few pros and cons to each) except the Rift is $200-$300 cheaper. I'll also correct any mistakes by the other person, such as statements like "the Oculus cant do roomscale". https://myip.kim/

    At that point, Vive people get really mad and start shilling even harder. https://birthdaywishes.onl/

    Are these people just that bothered by the fact that they wasted an extra few hundred bucks for no benefit?https://elecpay.in/tneb/

Sign In or Register to comment.