Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Issue in Unity Social Starter example invitation system

Hi all,
We are working on a multiplayer project for Gear VR, consisting of an environment sharing between two guest, so we just started with the Oculus Social Starter for Unity from the AssetStore.

 The issue we encountered is that the invitation between user A to user B and viceversa works only the first time we install the App, from the second time onwards, the Oculus UI keeps telling the user “Cannot invite this friend”.

This gets fixed only by uninstalling and reinstalling the application, clearing the application data has no effect.

Some data:

  • Environment is Unity 5.5.4f1 with the latest platform SDK update
  • The app is the vanilla AssetStore Oculus Social Starter, we tried also with our main app with the same result
  • We’re using both the white and black GearVR with S6 and S7
  • Tried more or less all kind of connection combinations: same router, different hotspots, 4G connections

Can someone help us ?
Thanks
Alessio




Comments

  • a.bottossoa.bottosso Posts: 4
    NerveGear
    edited December 2017
    Hi @imperativity,
    Thanks for your reply.
    We fixed that using a custom UI approach instead of the "LaunchInvitableUserFlow()" one..
    Best regards.
    Alessio 
Sign In or Register to comment.