Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums will be revoked at the discretion of Oculus staff.
New to the forums? Click here to read the How To guide. -- Developers click here.

Users unable to find or use Preview Apps / No confirmation email is sent

When I add a user to my Preview App, their email address is added to Subscribed Users and they never receive an email invite. As a result, they are never able to find our preview app in their apps.

The one place the app is visible is on Preview Apps page in the account section: https://secure.oculus.com/my/preview-apps, but this only allows them to unsubscribe.

Am I doing something wrong or did I find a glitch in the system?

Comments

  • imperativityimperativity Posts: 3,587 Valuable Player
    Moving to platform sdk forum.
  • imperativityimperativity Posts: 3,587 Valuable Player
    edited February 5
    Hi,

    Welcome to the Oculus Developer Forums.

    Two questions:

    1) Do the emails have any characters like "." "-" in them?

    2) Have your user's checked their spam folders? Often times these confirmation emails are found there for some reason.

    Once I have these answers we can look into whats going on behind the scenes with your developer organization.
  • madefireengrmadefireengr Posts: 3
    NerveGear
    Thanks for your triage and response.

    1) No. They are all in the format <[email protected]> with only letters in the username. The only exception is one test account that I made using the + character (for creating multiple Oculus accounts from the same Gmail address). We have used this practice successfully in other Oculus project channels.
    2) Yes. Also note that, in the dashboard UI, addresses are added directly to Subscribed Users, not Pending Users. The users seem to never be in the intermediate pending state.
  • dithernetdithernet Posts: 27
    Brain Burst
    Same problem. The user never receive the invitation email.
  • GruguirGruguir Posts: 15
    NerveGear
    Looks like that issue was always there and apparently never solved.
  • imperativityimperativity Posts: 3,587 Valuable Player
    edited March 12
    @madefireengr
    @dithernet
    @Gruguir

    Are you all still experiencing this issue currently?

    **Make sure to tag me in this post so I can triage this issue.
  • dithernetdithernet Posts: 27
    Brain Burst
    yes @imperativity the problem is still there.  :'( :
  • imperativityimperativity Posts: 3,587 Valuable Player
    @dithernet

    OK--thanks for confirming. Can you private message me your org id and your application id experiencing this issue? Also, if you could try adding an email that does not forward a request, that would be great for updated logs on our back-end. Thanks!
  • lukeskywatcherlukeskywatcher Posts: 99 Oculus Start Member
    I added one user that had same prob, immediately went straight to subscribed Users, not Pending Users, no preview app showing. Others Users I added  operated normally, seems random.
    "Also, if you could try adding an email that does not forward a request, that would be great for updated logs on our back-end. Thanks! "
    How do i add an email that does not forward a request? Is this not the problem? Should i remove problem user email from subscribed, and re-submit that email?
    thanks v much
  • lukeskywatcherlukeskywatcher Posts: 99 Oculus Start Member
    Sorry @imperativity meant to tag you for previous post

  • dithernetdithernet Posts: 27
    Brain Burst
    @imperativity the problem is still there. Do you have a solution?
  • dithernetdithernet Posts: 27
    Brain Burst
    I am really impressed with the responsiveness on this forum.  B) Good job guys
  • yurygural1982yurygural1982 Posts: 1
    NerveGear
    edited May 7
    Hi. A developer sent me a link for an alpha app. When i clicked the link it was added to My Preview Apps. I can see a logo of the app. And it says Subscribed above the logo. From there I have only one option which is Unsubscribe. How can I add this app to my library so that I can launch it on my Gear VR?
    Thank you

  • elbertperezelbertperez Posts: 1
    NerveGear
    I too am unable to find my preview apps in the Oculus Store both on the phone and headset. I've scrolled all the way to the bottom and found nothing. My account says subscribed as well
  • djwilday_amazondjwilday_amazon Posts: 1
    NerveGear
    edited June 6
    Confirmation emails are not being sent to my channel users.  The users are stuck in Pending Users.  Both users are gmail accounts, one has a extra '.' in the name the other does not.  Any idea what's going wrong?
  • noemisnoemis Posts: 19
    NerveGear
    Ok, I have also this problem: I invite an user account to a release channel and on "my preview apps" the app appears under "invited" but there is no possibility to accept the invitation. An invitation email is sent sometimes, but not always and mostly with a very long delay. Dear Oculus, can you PLEASE let us accept invitations in the "my preview apps" section (link)?

  • noemisnoemis Posts: 19
    NerveGear
    Ok, I have also this problem: I invite an user account to a release channel and on "my preview apps" the app appears under "invited" but there is no possibility to accept the invitation. An invitation email is sent sometimes, but not always and mostly with a very long delay. Dear Oculus, can you PLEASE let us accept invitations in the "my preview apps" section (link)?

  • vromerodfvromerodf Posts: 5
    NerveGear
    edited June 18
    We are experiencing the same issue when attempting to test our app through the Library on Oculus Go.

    If there is a workaround for sideloading apps and getting the system to run them without licensing issues, that might help.

    As it stands, however, we are completely blocked from testing our app on Oculus Go and we are due for submission this week. Please let me know if we can provide any additional details to work past this issue.
  • nrudzicznrudzicz Posts: 18
    NerveGear
    Just here to add that it's happening to me too. I'm the developer on our project and was testing by side-loading the .apk onto the Go. I just recently added myself to the Alpha channel for the game, and now I can no longer launch side-loaded apks, nor can I find the app in my library under "Not Installed" or "My Preview Apps."

    I'll just link back to these two other threads that have also reported a similar issue.
  • JourneyEntJourneyEnt Posts: 1
    NerveGear
    Ditto.  Very frustrating.
  • play_eduplay_edu Posts: 12
    NerveGear
    I have the same issue any solution for this
  • maxBrmaxBr Posts: 67
    Hiro Protagonist
    Use the search function on the GO. Type in the exact name and you might find the app (after accepting the email invite first of course)
  • LukeyBluLukeyBlu Posts: 1
    NerveGear
    Hi. A developer sent me a link for an alpha app. When i clicked the link it was added to My Preview Apps. I can see a logo of the app. And it says Subscribed above the logo. From there I have only one option which is Unsubscribe. How can I add this app to my library so that I can launch it on my Gear VR?
    Thank you

    @imperativity
    Hey I am in a similar Boat to this guy. thought i would tag as you may have lost contact with this thread.

    Also I may have found a step forward to those still looking for a solution.
    On Oculus home (Desktop) go to settings>Beta> and toggle "Public test channel" 
    I'm still trying to figure out how to launch the app, but figured this was a little bit of progress anywhoo...
  • Julien.TamadeJulien.Tamade Posts: 4
    NerveGear
    I am having this issue still all the way in October. I have an app on the alpha channel release and when I accept the invitation for it. I don't see any "My Preview Apps" section in the store. The headset recently updated to a newer version but before that it worked. I am about to be releasing my app to others through this channel and if they can't download that it is a big issue. Has this still not been fixed? Is there any way to revert to an older version? @imperativity
  • mythicalcitymythicalcity Posts: 9 Oculus Start Member
    Has anyone found any solution to this, specifically for the Oculus Go? The apps show up in the My Preview Apps section on the website, but there doesn't appear to be any way to install the app on the Go.
  • bill911stonebill911stone Posts: 5
    NerveGear
    I got it to work by using the Go's Search to search for the app. When the app name appeared in the results list, I clicked it to perform the install.
  • ubc_oculus1ubc_oculus1 Posts: 2
    NerveGear
    edited December 5
    Months and months passed by here without a proper answer from Oculus staff!!!

    Solution: I had to hard reset the oculus (from the mobile app), refresh the mobile app (log off / log in) and only then it worked for me. BTW, the user had a "_" symbol in his email. 
  • TageolssonTageolsson Posts: 1
    NerveGear
    I also have this problem. People recieve the mail and the invitation works. The app appears on the oculus website under "my preview apps" but not in the oculus phone app, neither in the oculus Go library.

    The workaround that some of you people mention, searching for the exact app name in the oculus go, works for us though.
Sign In or Register to comment.