Force 45fps doesn't work? — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Force 45fps doesn't work?

IcyJeffIcyJeff Posts: 1
NerveGear
We make architectural visualization software which allows users to walk through an interior space that they design. We have worked to optimize as much as we can, but because users can create their own designs, we will always run into cases where they try to put in more than we can render at 90fps. When this happens, the rendering starts to alternate between 45fps and 90fps, and it feels very jittery. What we would like to do is give the user the option to lock the framerate to 45. On Oculus, ASW should fill in the extra frames and it shouldn't look too bad. We have tried setting Asynchronous Spacewarp in the OculusDebugTool to 'Force 45fps, ASW disabled', and that works, but then we lose the benefits of ASW. When we set it to 'Force 45fps, ASW enabled' the framerate sometimes stays near 45 fps for a while, but after some time of walking around, it always unlocks and starts to vary up to 60-70fps. Is there anything else we can do? Is it a known issue that 'Force 45fps, ASW enabled' doesn't work?

We are using Unity 2017.3 and Oculus version 1.23
Tagged:
Sign In or Register to comment.