Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Virtual Reality SDK Oculus failed to initialize, why?

nerdVRBuddynerdVRBuddy Posts: 77
Hiro Protagonist
Ok so i downloaded Unity 2017.4.0f1
I also got the latest Oculus Utilities.

And when i press play this are the messages i get

Virtual Reality SDK Oculus failed to initialize.
Attempting to enable OpenVR instead.

XR: OpenVR Error! OpenVR failed initialization with error code VRInitError_Init_PathRegistryNotFound: "Installation path could not be located (110)"!

Virtual Reality SDK OpenVR failed to initialize.
Attempting to enable None instead.


Unity v2017.4.0f1, Oculus Utilities v1.24.0, OVRPlugin v1.24.0, SDK v0.0.0.
UnityEngine.Debug:Log(Object)
OVRManager:Awake() (at Assets/OVR/Scripts/OVRManager.cs:904)

*****************
I don't know why i get that. In My Player Settings  /XR Settings  I have Virtual Reality Supported checked and then listed are the Oculus  with an arrow pointing to it and then below that OpenVR.

And i intend to build for the RIft.
This process worked fine back in Unity 5 when i tried it. But what should i do to make it work in Unity 2017.4?







Comments

  • markhansavenmarkhansaven Posts: 21
    Brain Burst
    edited March 2018
    Same thing here. Just installed on a brand new third computer running windows 10 home. 

    Oculus Utilities was not installed. I tried the latest Unity version 2017.4. VR is broken in Unity completely.
  • AndreyBlueGojiAndreyBlueGoji Posts: 1
    NerveGear
    Same thing in Unity 2017.4.0f1. Installed Unity 2017.3.1p4, there is a exactly same trouble.

    Any solved this?
  • markhansavenmarkhansaven Posts: 21
    Brain Burst
    Same thing in Unity 2017.4.0f1. Installed Unity 2017.3.1p4, there is a exactly same trouble.

    Any solved this?
    There doesn't seem to be any acknowledgement of this. Unity is supposed to work out of the box with virtual reality, and as of right now it's broken on all three of my computers with a fresh install on each one.
  • vbalbiovbalbio Posts: 9
    NerveGear
    Same here!
  • philip.prins.philip.prins. Posts: 1
    NerveGear
    Same Problem
    Virtual Reality SDK Oculus failed to initialize.
  • AntimonAntimon Posts: 4
    NerveGear
    May 14th, 2018, this issue still seems not to be solved for me as well. Is there any update?
  • rikkcareyrikkcarey Posts: 7
    NerveGear
    NOTE: I am currently building on a Mac with Target=Windows. Is this even possible?

    Same issue for me. Clean install of Unity 2018.1.1f1. I carefully followed all directions on Oculus developers site, installed latest Oculus Utilities 1.26.0, Player Settings: Virtual Reality enabled and XR Settings:SDK=Oculus VR. I created new project, a new scene, created a cube, and clicked Run
    ==> "Virtual Reality SDK Oculus failed to initialize."
      

  • Prana_StudiosPrana_Studios Posts: 1
    NerveGear
    edited August 2018
    Hi, Im having the same issue. Confirmed that I have the Oculus Runtime running,

    Other things I have already checked:
    • Everything is updated to the latest version
    • Ive tried the #if UNITY_EDITOR fix, but the XRSettings.enabled flag goes back to false.
    If anyone could point me in the right direction that would be great!
  • yarwadyarwad Posts: 5
    NerveGear
    Why isn't there more attention given to this issue?  I'm dealing with the same thing and it seems like there's no answer.
  • LatexPantherLatexPanther Posts: 1 Oculus Start Member
    As imperativity posted above, I clicked on the checkbox next to "Virtual Reality Supported" located under Edit > Project Settings > Player. For some odd reason my Oculus RIft worked after that.
  • eleistereleister Posts: 2
    NerveGear
    This just started happening to me with the Oculus Go - takes forever to build, build is successful but then Oculus Go error is that the app has stopped working. Made no changes - all of sudden no way to test. 
  • mynameisjohnjmynameisjohnj Posts: 3
    NerveGear
    edited June 26
    After some trial and error I've gotten around this issue.

    I recently upgraded my Oculus integration to 1.3.8, Unity 2109.1.2f (though the Unity version doesn't seem to matter), and got this message when running on the PC Rift:

    Virtual Reality SDK Oculus failed to initialize.
    Will attempt to enable None instead.

    I was able to build to the GO fine, just the Rift had this issue (I don't have a Quest or Rift S so I can't speak to those.)

    I narrowed it down to the spatializer plug-in. If I delete the oculus integration, import it again, I get two plug-in prompts. One is about upgrading the integration to 1.3.8 (which I accept), and the other is about upgrading the spatializer plug-in. Here I say "Delete new plug-in", then restart the Unity Editor and everything works as expected.

    It'd be unfortunate if I actually cared about the spatializer plug-in... but I don't.
  • RalphSchaedlerRalphSchaedler Posts: 6 Oculus Start Member
    @mynameisjohnj thanks for the solution. Had the same problem.
  • angularsenangularsen Posts: 11
    NerveGear
    This is still an issue on Unity 2019.2.4f on an empty project and installing the Oculus Integration 1.40 package. If you click Upgrade when prompted to upgrade the spatializer to 1.40's version, the entire Oculus SDK integration stops working. I'm kind of amazed this is still a thing as it has been for the majority of the last 9 months or so when I first started toying with the spatializer plugin.
  • angularsenangularsen Posts: 11
    NerveGear
    edited September 6
    Using the recommended versions of Unity and Oculus Integration does not work!

    Oculus team, please look into this long-standing issue.

    I've tried to follow the instructions to the letter and I can still consistently reproduce this problem.

    https://developer.oculus.com/documentation/unity/latest/concepts/unity-req/
    Oculus states that these versions are recommended (some outdated docs specify Unity 5 though):
    • 2017.4 LTS
    • 2018.4 LTS
    • 2019.1.2f1

    Repro
    I started a new Unity project with 2019.1.2f1 and 3D project template:

    1. Enabled VR in player settings
    2. Installed Oculus Integration 1.40 from Asset Store
    3. Clicked 'Upgrade' when prompted to upgrade Utilities from 'none to 1.40, clicked 'no' to restart
    4. Clicked 'Upgrade' when prompted to upgrade Spatializer plugin from 'none' to 1.40, clicked 'no' to restart
    5. No more prompts, so restarted Unity
    6. Enter play mode with default empty scene that has a light and a camera
    7. Console output says Virtual Reality SDK Oculus failed to initialize and it will either fallback to OpenVR or None, depending on your settings.

    Am I doing anything wrong?

    This is the case for a lot of people it seems, but I must assume that it is not the case for everyone so maybe this is PC or environment specific. I'm happy to provide any logs or assist in any way if someone from Oculus can please take a look at this and figure out why this happens.

    It's been this way for me for most versions since 1.31 or around that time and forums have plenty of posts about the same issue.

    Workaround: Do not upgrade spatializer plugin
    In point 4 click 'Don't upgrade' or 'Delete' when prompted to upgrade Spatializer plugin.

    The downside is that spatializer features seems to stop working. At least ambisonic clips don't play for me.
    I tried upgrading to Spatializer 1.36 and that did not help. Maybe some other versions works better.

    The bundled spatializer version in Unity seems to be around 1.13, the version number is logged in one of the spatializer sample scenes.
  • goodbyesquaregoodbyesquare Posts: 3
    NerveGear
    @angularsen Have you tried pressing yes to the restart prompt? I've never had any issues like you've described with different versions (1.38,1.39,1.40) but I've always pressed yes to restart.
  • angularsenangularsen Posts: 11
    NerveGear
    edited September 13
    @goodbyesquare Good question, I have tried before, but I did give it another go: 
    Upgrade OVRPlugin (orwhatsitsname)? Yes
    Restart? Yes
    Upgrade spatializer? Yes (it asks before restart happens)
    Restart? Yes
    Wait for Unity to restart.
    Load Oculus SampleScene, enter play mode and boom:

    Virtual Reality SDK Oculus failed to initialize.
    Will attempt to enable None instead.

    This was on 2019.2.4f1.
  • CTNRSMCTNRSM Posts: 7
    NerveGear
    Thank you so much for documenting this issue. Our department has been struggling with this issue recently and we were able to solve it thanks to this thread. Before, the game would not run in the headset when run from the editor and would say: "Unity v2019.1.0f2, Oculus Utilities v1.40.0, OVRPlugin v1.40.0, SDK v0.0.0." in the console. After disabling the spatializer plugin, it works again!

    For those of you who found this thread, have no need for the Spatializer plugin, already have the upgraded spatializer plugin and can't seem to get your Oculus to work in the Unity Editor with Oculus reporting the sdk as "SDK v0.0.0" in the console, here's how I fixed it:

    Close the Oculus application just to be sure. Open your project. Navigate to where the plugin is; for me, it was located in Assets -> Oculus -> Spatializer -> Plugins. You might have two separate folders: x86 and x86_64. Go into both folders and select the dll file inside each folder. In the inspector panel, disable the plugins across the board. Under the "Select platforms for plugin" section, uncheck it for all platforms. Then under "Plugin load settings", uncheck the "Load on startup" option. Restart Unity, and the plugin will be disabled. When you hit Play, the Oculus app should open, and your game will hopefully be running in the headset again.

    Thanks again @angularsen, you really saved my skin this week!
  • OculalfredoOculalfredo Posts: 1
    NerveGear
    No, it doesn't work!
  • DebbieMoodyDebbieMoody Posts: 23 Oculus Start Member
    @CTNRSM Still not working for me, using Unity 2019.2.5f1

    Also, there's no option to disable the spazialiser in the inspector when following your steps. Help please
  • hgulgenhgulgen Posts: 4
    NerveGear
    It works for me thanks.
  • CTNRSMCTNRSM Posts: 7
    NerveGear
    @CTNRSM Still not working for me, using Unity 2019.2.5f1

    Also, there's no option to disable the spazialiser in the inspector when following your steps. Help please
    When you select the spatializer plugin in the Unity editor, the inspector should show something like this:



    I'm not sure what else you could do if it doesn't work. I wish I could offer more help, I can only tell you what solved the issue for me.
  • rocketchickenrocketchicken Posts: 2
    NerveGear
    I seem to be having a related issue that I posted in the Unity forums (along with mis-spelling "Oculus"):

    https://forum.unity.com/threads/occulus-editor-integration-stopped-working.752003/

    In short, having the spatializer enabled causes Unity to try to launch in the headset on boot, which doesn't make a lot of sense. The loading screen gets stuck and any further attempts to start the editor fail to render in the headset. If I disable the spatializer on boot, but then turn it on once I'm in Unity, everything works. This behavior also started somewhat out of the blue--this exact setup was working fine until it stopped working. At that point, even with a new Unity install, updated tools, and updated Oculus app, it stayed broken.
Sign In or Register to comment.