Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

HELP!!!!! Baking issue with Lightmaps

EWalker3EWalker3 Posts: 11 Oculus Start Member
Hi Guys! I am currently experiencing some issues with baking light maps in Maya and Unity. I am getting this banding ripple effect that appear on the surface of my mesh (See screenshot attached). I am still getting this issue to occur even at a high texture resolution and sample rate. Also adding more light to the scene seems to add to the problem when rendering my bake. I am currently build my scene specifically for mobile used for the Gear VR. Can anyone offer me any advice or tips on how to render a cleaner bake without all the left-over artifacting appearing in the scene? Thank you in advance.

Comments

  • MadeinBrooklynGamesMadeinBrooklynGames Posts: 28 Oculus Start Member
    I would love to understand how to solve this problem as well. I ran into the same issue in my game.
  • NinjaGGNinjaGG Posts: 251 Oculus Staff
    edited April 2018

    This looks to be an issue related to Unity. Which version are you using?

    In any case, you may want to check a few things on your end. Mainly:

    - Your lightmaps may be compressed. Try disabling "Compress Lightmaps" under Lighting -> Scene -> Lightmapping Settings.
    - If using Baked Indirect for your Lighting Mode, try switching to "Subtractive Lighting" mode under Lighting -> Scene -> Mixed Lighting.

    Refer to this Unity forum thread related to a discussion on lightmap banding to see if you can diagnose the issue: https://forum.unity.com/threads/enlighten-causing-severe-banding-in-lightmaps.456110

    If you need immediate help or want additional support/context on an issue you are having with our platform or integrations:

    1. Gather any and all logs, screenshots, and version numbers of relevant software (Oculus SDK, engine, etc.)
    2. Please submit a ticket here (include what you've gathered in step 1).
    3. Tag me @NinjaGaijin once you have done so!
  • kinematic_rigidboykinematic_rigidboy Posts: 1
    NerveGear
    After none of the above worked, I found that adding a post-processing layer removes the banding.
    Post-processing profile can be empty ¯\_(ツ)_/¯ 
    (Unity 2018.3)
  • Thunderbox.EntThunderbox.Ent Posts: 60 Oculus Start Member
    What shader are you using?
  • dmitri.savine.1dmitri.savine.1 Posts: 1
    NerveGear
    We've had this problem too. It is caused by half precision in Unreal mobile shader. Forcing it to full precision should solve this.
Sign In or Register to comment.