Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Anyone have trouble with Oculus Go disappearing from 'adb devices'?

I'm on Windows. Using "CodeWorks for Android 1R6u1" as my Android environment (as recommended for Unreal Engine).

I can successfully see my Oculus Go in my "adb devices" list and communicate with it through Unreal Engine 4, however after I unplug / plug the USB cable it will never show back up under "adb devices". I have to manually enter a "adb kill-server & adb start-server" command, and then the next cable insert will successfully show the device.

Anyone else experiencing this? It's annoying to do this song and dance every time the device is unplugged.
Tagged:
«1

Comments

  • aweidenhammeraweidenhammer Posts: 19
    NerveGear
    Yes, I've just started today, and I'm having no luck getting the Go to recognize as an authorized adb device no matter how many rsa keys I accept.  Driving me crazy.  
  • SC_NicholasSC_Nicholas Posts: 6
    NerveGear
    edited May 2018
    Yes, I've just started today, and I'm having no luck getting the Go to recognize as an authorized adb device no matter how many rsa keys I accept.  Driving me crazy.  
    Are you on Windows? Sometimes I have to do black magic like "adb kill-server" multiple times until it is actually dead, and only then "adb start-server" and THEN plug in the Go. This is after accepting the RSA key permanently inside the headset itself.

    Boggles my mind there is so much difficulty here. I'm on a newly formatted Windows 10 machine with no other weirdness installed other than Unreal and CodeWorks for Android. I also experience this on a different Windows 10 machine.

    Maybe CodeWorks is the problem?
  • KdragosKdragos Posts: 19 Oculus Start Member
    I'm seeing the same problem. I'm not using CodeWorks. I'm also on a Windows machine. I've already permanently accepted the RSA key. I've seen the device show up a few times, but not any more. I've tried the kill and start server commands but no luck. :( 
  • sinothsinoth Posts: 67
    Hiro Protagonist
    Kdragos said:
    I'm seeing the same problem. I'm not using CodeWorks. I'm also on a Windows machine. I've already permanently accepted the RSA key. I've seen the device show up a few times, but not any more. I've tried the kill and start server commands but no luck. :( 

    Try this... and I know it's ridiculous, but I have pretty good luck with this sequence.

    Plug in the USB cable
    If it doesn't show up under "adb devices", do the following:
    1. Close Unreal/Unity
    2. Click the "Safely remove hardware and eject media" system tray icon (the one that looks like a USB stick) and select Eject VR Headset
    3. Wait 10 seconds
    4. Issue an "adb kill-server" command
    5. Wait a few seconds
    6. Kill the server a second time to make sure it's dead...
    7. Issue an "adb start-server" command
    8. Wait a few seconds
    9. Pray
    10. Plug in the headset
    11. HOPEFULLY it shows up now
    12. DON'T UNPLUG THE HEADSET, EVER AGAIN

    Once it shows up it seems to be stable. I've had good luck developing on the device. It's just crazy how fragile the interface seems to be :/ I'm not sure if the problem is with the Go, the driver, or the Android framework.
  • MaxArchMaxArch Posts: 128 Oculus Start Member
    edited May 2018
    +1 @Sinoth - you're 11 steps work. Step 12 will fail Im afraid. Would be nice if there was a step by step list for developers for the Unreal Engine (and Unity) that we could follow to get something simple working (Android version, project settings etc etc).
  • GEMISISGEMISIS Posts: 101 Oculus Start Member
    Running into issues with this as well. Created a new thread for mine, but not sure if anyone else is having issues authorizing their PC for development. Followed the guide provided here, but still no luck :(
  • aweidenhammeraweidenhammer Posts: 19
    NerveGear
    I've been trying to post my answer for days, but this strange forum won't let me.
  • aweidenhammeraweidenhammer Posts: 19
    NerveGear
    There, now that that test worked.  I found the problem was with the Oculus adb drivers.  Uninstall them.  Instead, use the samsung usb drivers.  I had a post all written up with links and everything, but this forum wouldn't let me post it.  I have no idea why. 
  • aweidenhammeraweidenhammer Posts: 19
    NerveGear
    edited May 2018
    "Your comment will appear after it is approved"

    That's what I get every time I try to paste a link.  Oh well, good luck!
  • MaxArchMaxArch Posts: 128 Oculus Start Member
    A trick that worked a few times for me already is restarting the GO while keeping the usb cables connected.
  • SC_NicholasSC_Nicholas Posts: 6
    NerveGear
    maxBr said:
    A trick that worked a few times for me already is restarting the GO while keeping the usb cables connected.

    What is the fastest way you've found to restart the device?
  • MaxArchMaxArch Posts: 128 Oculus Start Member
    keep pressing the power button and choose - restart
  • aweidenhammeraweidenhammer Posts: 19
    NerveGear
    Ok, this has literally taken me all #%#$^ day.  My problem wasn't killing and restarting adb.  It was faulty adb drivers posted by oculus in the following setup guide:
    Setup Go

    It mentions there to install their special adb driver and provides a link.  Don't use this.  You are in for a day of pain;)
    Instead, follow this conflicting advice in their other docs:
    Setup Android

    Specifically, download and install the Samsung usb drivers.  This worked for me and I was instantly able to see my device as adb and deployed my app in a couple minutes.  Amazing what good and accurate docs and drivers can do, and what harm bad ones can do.  

    sorry for the rant.  Sorry Oculus, but please remove the adb drivers if they don't work.  I couldn't get them to be stable.  I'm on:
    Windows 10 Pro x64
    AMD Threadripper 1950x

    I have a number of dev environments set up including those for rift/vive and ios
  • aweidenhammeraweidenhammer Posts: 19
    NerveGear
    GEMISIS said:
    Running into issues with this as well. Created a new thread for mine, but not sure if anyone else is having issues authorizing their PC for development. Followed the guide provided here, but still no luck :(
    That was the same problem I had.  The drivers linked in that guide would not work for me.  I had to uninstall them and instead install the drivers from samsung, linked in another doc here
  • aweidenhammeraweidenhammer Posts: 19
    NerveGear
    GEMISIS said:
    Running into issues with this as well. Created a new thread for mine, but not sure if anyone else is having issues authorizing their PC for development. Followed the guide provided here, but still no luck :(
    That was the same problem I had.  The drivers linked in that guide would not work for me.  I had to uninstall them and instead install the drivers from samsung, linked in another doc here.  Oculus should remove those drivers and reference to them until it's sorted out and works.
  • GEMISISGEMISIS Posts: 101 Oculus Start Member
    Looks like your links finally worked @aweidenhammer haha Thanks for that, just tested and it still was not working. However, after a bit more fussing tonight I finally figured it out. Make sure you do NOT have an unlock pattern set! Doing so will make you unable to accept the authorization for a new connection! Not sure if there are any admins tracking this page, but if so, this should be looked into ;)
  • NerdsterNerdster Posts: 1
    NerveGear
    When you connect your headset to the computer do not select the Allow USB option in the headset, that will allow you to continue using ADB. You cannot have ADB and USB together. 
  • KdragosKdragos Posts: 19 Oculus Start Member
    Here's what I've done that seems to have worked: I did a factory reset on my Go headset and uninstalled the Windows Go driver. I didn't do the permanently accept the computer thing. Now, it seems to work just fine. My theory is that there's something in the driver that's the problem. 
  • preston.mccauleypreston.mccauley Posts: 46 Oculus Start Member
    Ive been at this for a few hours. How do you even uninstall the go adb. I don't see any option to uninstall this... I also tried to uninstall the samsung one and it gives me a japanese error message. Seems like this dev process would be better documented.
  • AQfumesAQfumes Posts: 133
    Art3mis
    It appears a 2.0 version of the Oculus Go adb drivers has been updated today. I haven't tried it yet. 
    https://developer.oculus.com/downloads/package/oculus-go-adb-drivers/

  • vr_marcovr_marco Posts: 39 Oculus Start Member
    edited May 2018
    I had the same issues and I solved it through the Oculus Go adb drivers 2.0, but first the old drivers need to be uninstalled as follows:
    - Plug in your Oculus Go and leave it connected
    - Open the Windows Device Manager (right click on the windows symbol in taskbar the then choose Device Manager)

    - Find the Oculus Device entry and open it
    - Right click on Oculus Composite ADB interface
    - Choose Uninstall Device
    - Tick Delete the driver software for this device
    - Confirm
    - Download the new Oculus Go adb driver 2.0 here: https://developer.oculus.com/downloads/package/oculus-go-adb-drivers/
    - Unzip it the downloaded file
    - Open the unzipped folder and navigate to the usb_driver folder
    - Locate the file named android_winusb.inf
    - Right click on it and choose Install
    - Make sure you get a confirmation message the driver was installed
    - Unplug and plug in your Oculus Go

    Now open a command prompt with admin rights and type: adb devices
    Your Oculus Go devices should be listed. Enjoy!


  • FieldOfVisionFieldOfVision Posts: 206 Oculus Start Member
    Been having this issue too since I got my Go. Will try those options this evening! Fingers crossed.

    Check out our VR games here: www.FieldOf.Vision
  • gonzaloecu84gonzaloecu84 Posts: 2
    NerveGear
    Followed your instructions and installed the oculus go adb driver 2.0. the device appears as unauthorized when connected but as soon as i accept to trust the computer inside oculus go it disappears from the list not sure if I'm the only one with this issue
  • mitchallenmitchallen Posts: 2
    NerveGear
    On Windows 10 using a Lenovo Yoga laptop neither ADB driver 1.0 or 2.0 worked.  I removed both. Then when I plugged in the Go, Windows popped up notifications that it was installing VR-Headset.  Then after a few more notifications adb devices could find it.   

    I had it connected yesterday and the Go gave me the permission screen then it stopped working. I think because I thought I still had to install the driver as a next step. That apparently broke it.

    One issue I had is that Developer mode isn't persistent. Every time I experiment I have to go back in to the Oculus App on my iPhone and set it.

    When I put on the Go, down at the bottom of the first screen (where you are asked to set your controller) it says:

    "(You are in developer mode. Press any volume key to enter)"

    Check that and make sure you are in the right mode.

  • preston.mccauleypreston.mccauley Posts: 46 Oculus Start Member
    Still no luck. I've factory reset, I've rolled out all drivers, I installed the ADB 2.0 driver... I got the permission screen accepted it but unity still fails to recognize it when trying to build out...I'm kind out of ideas here. So if you got any more keep em coming. I've tried all the steps above.  - For a brief moment yesterday I prayed and i saw the device in the dropdown in unity - nothing since then.
  • aweidenhammeraweidenhammer Posts: 19
    NerveGear
    Preston, as mentioned further above, have you tried the Samsung usb drivers instead?
  • ColeSanColeSan Posts: 1
    NerveGear
    I still seem to have the same issues with adb 2.0. It may be a little bit more consistent but it still does not work 100% of the time and I must unplug and replug my device in a few times for it to be recognized. Not the end of the world, but still a bit of an inconvenience. 
  • preston.mccauleypreston.mccauley Posts: 46 Oculus Start Member
    edited May 2018
    The samsung drivers did not work either. I've actually wiped my windows install complete fresh, setting up java, and everything right now and used the oculus go 2.0 - About to test it again.

    Update: Complete new install of windows Oculus Go 2.0 driver doesn't work. 


  • preston.mccauleypreston.mccauley Posts: 46 Oculus Start Member
    edited May 2018
    Slight progress, I went back to the samsung drivers and now i can see the device in unity. Of course when I build out to the device it now says ...
Sign In or Register to comment.