Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Oculus GO resolution aliasing

szirtestszirtest Posts: 7
NerveGear
Hi I'm been doing some tests on the GO with Unity 2018 and I'm noticing that it's looking very jaggy even with MSAA set to maximum (with MSAA off its horrendous). To be fair its an tough case because they are cartoony buildings (vertical and horizontal lines) - but with the slight increase in resolution of the GO over the Rift I expected it to at least look similar to what I get on the Rift.

Btw. I'm using the OVR Manager.

Is there a possibility I'm doing something stupid? or is anyone else finding the same?

Comments

  • onnevanonnevan Posts: 3
    NerveGear
    Hi, I'm experiencing the same problem with aliasing, and it happens in vertical and horizontal structures like buildings but not in textures. I've tried the above advice, except the ones regarding OVR Manager since I'm not using it and nothing seems to help. Multisampling Antialiasing don't seem to do anything event at 8x samples. Any other idea why this is happening?
  • xsdanielxsdaniel Posts: 5
    NerveGear
    edited August 2018
    Hi, same here.
    This is what I've tried without success:

    1. The five advises from @imperativity. Just in case, the number one is different in newer versions of Unity;
    UnityEngine.XR.XRSettings.eyeTextureResolutionScale
    2. Linear instead of Gamma. But the scene becomes darker, and actually, @imperativity suggests to use Gamma.

    3. Change the quality settings through code. It seems to work on GearVR but not for OculusGo.

    4. Use the AA from Post Processing Stack asset.

    5. Follow the instructions and settings for mobile VR, but using Linear instead of Gamma because number 2. 

    If there is any other advise to try, please let us know!
  • JoeS2018JoeS2018 Posts: 28 Oculus Start Member
    @xsdaniel, did you ever find a solution to the aliasing problem?  I'm struggling with the same thing now (also on Go).

  • xsdanielxsdaniel Posts: 5
    NerveGear
    JoeS2018 said:
    @xsdaniel, did you ever find a solution to the aliasing problem?  I'm struggling with the same thing now (also on Go).

    No :neutral:
    I am actually using different 3D models and the issue persists, -so it is not about the 3D objects-. I have tried every single method but it doesn't work. If you find something please let us know! 
  • beep2bleepbeep2bleep Posts: 41 Oculus Start Member
    Anyone find a solution?  I'm having this same issue Unity 2018.2 I've tried everything except 4 (since they don't have MSAA) listed above with the same issue.
  • beep2bleepbeep2bleep Posts: 41 Oculus Start Member
    Anyone find a solution?  I'm having this same issue Unity 2018.2 I've tried everything except 4 (since they don't have MSAA) listed above with the same issue.
    I found the problem.  I was looking at the interior of an object that was using the Transparent/Cutout Shader.  The inside of objects using this shader do not respond to MSAA. I found setting QualitySettings.antiAliasing = 8; and changing Transparent/Cutout to Transparent/Diffuse together fixed my MSAA issue.  Hopefully, now the store team will review my game for inclusion into the store or at least give me some feedback.
  • xsdanielxsdaniel Posts: 5
    NerveGear
    edited October 2018
    Anyone find a solution?  I'm having this same issue Unity 2018.2 I've tried everything except 4 (since they don't have MSAA) listed above with the same issue.
    I found the problem.  I was looking at the interior of an object that was using the Transparent/Cutout Shader.  The inside of objects using this shader do not respond to MSAA. I found setting QualitySettings.antiAliasing = 8; and changing Transparent/Cutout to Transparent/Diffuse together fixed my MSAA issue.  Hopefully, now the store team will review my game for inclusion into the store or at least give me some feedback.
    It reminds me this article. I will give it a try.
    ___

    Update: No :-( - It didn't work for me since I am actually not using transparent shaders. However, based on the Standard shader, I will try to create a new one keeping in mind the advises from the article I mentioned.
  • Kareeem84Kareeem84 Posts: 1
    NerveGear
    edited October 2018
    This is very disappointing. Tried this from many angles but nothing is satisfying. I guess everyone else is using LWRP as well?
    Post Processing doesnt seem to work at all. One eye shows a blank color the other one the unity logo..
  • mareks.zirdzinsmareks.zirdzins Posts: 1
    NerveGear
    The solution usually is using MipMaps in Unity for textures. Check the Generate Mip Maps checkbox by selecting all the texture content you have, and that will do the trick. 
Sign In or Register to comment.