Oculus Go Internal Storage Path — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Oculus Go Internal Storage Path

Hi, I am trying to direct an app I have installed on the Go to a folder I have placed in the internal storage, but I do not know the path to access the internal storage. I have tried the same one I used previously for Cardboard (storage/emulated/0/myfolder), but that is not working - can anyone tell me the path for the Go's internal storage?
Thanks.

Comments

  • zivschneiderzivschneider Posts: 13 Oculus Start Member
    Hi there, I am having a similar issue. I've sideloaded a video file onto the Oculus Go and trying to play it on a Unity video player and not sure how to write the path correctly. Thanks!
  • technipfmctechnipfmc Posts: 4
    NerveGear
    @imperativity did you ever come up with this answer 
  • rupertrupert Posts: 46
    Brain Burst
    On Android you can use Environment.getExternalStorageDirectory(). In Unity it appears you have to use reflection to get to this same function.
  • doudoiddoudoid Posts: 7
    NerveGear
    Hey mate. Here's your path for the internal SD Mount: 
     /mnt/sdcard/myfolder
  • zivschneiderzivschneider Posts: 13 Oculus Start Member
    oconel said:
    Hey mate. Here's your path for the internal SD Mount: 
     /mnt/sdcard/myfolder
    that works! thank you so much,  you're a life save!
  • HbmDevHbmDev Posts: 1
    NerveGear
    Hi, I'm having the same problem.

    I'm trying to create a file via Unity in the Oculus Go's Android folder.
    "mnt/sdcard/myfolder" didnt work for me.
    In Unity, Write permission is External (Sd Card). Manifest is ok...

    Thank you guys
  • adammakadammak Posts: 1
    NerveGear
    HbmDev said:
    Hi, I'm having the same problem.

    I'm trying to create a file via Unity in the Oculus Go's Android folder.
    "mnt/sdcard/myfolder" didnt work for me.
    In Unity, Write permission is External (Sd Card). Manifest is ok...

    Thank you guys
    I had the same problem, despite that I had read_external_storage permission in my android manifest 
    I solved it by running adb command: shell pm grant [your bundle id] android.permission.READ_EXTERNAL_STORAGE
    After that my app could read from device storage
  • zed8.frzed8.fr Posts: 6
    NerveGear
    Hello all, I just would like to read a file from the oculus go in Unity. Specificly, via AVpro mediaplayer Android.
    The path "mnt/sdcard/myfolder" doesn't work for me :-)

  • DT7DT7 Posts: 1
    NerveGear
    Bit late on this but I got everything loading into unity with AVpro via  
    "string fixedPath = "/storage/emulated/0/Android/data/sdcard/" + videofilepath;" 
    where I created the folder "sdcard" I was never able to get "mnt/sdcard/" to work. Just sideload all your videos into that folder and you'll be able to access them in unity.  Hopefully this helps if anyone in the future needs this info. It was a trip figuring this out.
  • altdocsaltdocs Posts: 1
    NerveGear
    hey, did you try "/mnt/sdcard/"? I think just adding a / helped me 
  • creativeturtle2creativeturtle2 Posts: 2
    NerveGear
    Regarding AVPRO Plugin > videos sideloading on Oculus Go

    Hey guys I am in a very stressful situation. First of all I am not a programmer. I use mainly plugins to get my ideas realized. I have a 76 videofiles with 360 footage in mp4 and Ambisonic Audio with Opus Codec. When I just paste one of the videos inside the streamingassets folder in my project everything works fine but with all 76 I get packaging errors:

    CommandInvokationFailure: Android Asset Packaging Tool failed.
    C:\Users\tayyi\AppData\Local\Android\Sdk\build-tools\28.0.3\aapt.exe package -v -f -F raw.ap_ -A raw -0 "" --ignore-assets "!.svn:!.git:!.ds_store:!*.scc:.*:!CVS:!thumbs.db:!picasa.ini:!*~"

    stderr[
    raw\Seite4Ichdenkewirk�nnenanfangenHS.MP4: error: Invalid filename.  Unable to add.
    ]
    stdout[
    Found 34 custom asset files in raw
    ]
    exit code: 1
    UnityEditor.Android.Command.WaitForProgramToRun (UnityEditor.Utils.Program p, UnityEditor.Android.WaitingForProcessToExit waitingForProcessToExit, System.String errorMsg)
    UnityEditor.Android.Command.Run (System.Diagnostics.ProcessStartInfo psi, UnityEditor.Android.WaitingForProcessToExit waitingForProcessToExit, System.String errorMsg)
    UnityEditor.Android.PostProcessor.Tasks.TasksCommon.Exec (System.String command, System.String args, System.String workingdir, System.String errorMsg)
    UnityEditor.Android.PostProcessor.Tasks.AAPTPackage.AAPTPack (UnityEditor.Android.PostProcessor.PostProcessorContext context, System.String apkName, System.String directory, Boolean compress)
    UnityEditor.Android.PostProcessor.Tasks.AAPTPackage.Execute (UnityEditor.Android.PostProcessor.PostProcessorContext context)
    UnityEditor.Android.PostProcessor.PostProcessRunner.RunAllTasks (UnityEditor.Android.PostProcessor.PostProcessorContext context)
    UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)


    ———————-

    Renderheads the producers of AVpro suggested me this

    “It could be due to the file size.  If it is too big then the machine will run out of memory while trying to open it from StreamignAssets.  For large files we recommend copying it to the device and not including it into the StreamingAssets folder.”

    I mean the files are not more than 500mb each but maybe using so many in the streamingassets causes the packaging errors.

    So the question is how can I sideload the videos on the Oculus Go and tell AVPRO to get the videos from there? I couldn’t find any tutorials 


  • JacksonGordonJacksonGordon Posts: 138
    Art3mis
    Not positive if this is the issue, but in Unity it likes to have any 360 video appended with _360 before the extension.  I would try to change the filenames to  this convention and see if it helps.  Longshot but worth a try.
  • creativeturtle2creativeturtle2 Posts: 2
    NerveGear
    This works for simple playback on OculusGO but doesn’t solve the packaging problem of the streamingassets folder 
  • TheSwanCollectiveTheSwanCollective Posts: 12
    NerveGear
    Just want to say that I did everything on this page and it WORKS!!!!! :D
    Thank you all, it's amazing!

    Note that I had to change the command of @adammak to this one here to get it working:

    adb shell pm grant com.XXX.YYY android.permission.READ_EXTERNAL_STORAGE

    -> com.XXX.YYY is your chosen package name in unity's player settings


  • rafasanconrafasancon Posts: 2
    NerveGear
    Tried everything described here so far and none of them works :/
    /mnt/sdcard/...
    /storage/emulated/0/Android/data/...
    /storage/emulated/0/Android/data/sdcard/...
    All of them were tested using READ_EXTERNAL_STORAGE privileges granted using adb and the manifest
    Also I tried to find the path using reflection and it didn't work either.
    Please, any help would be extremely appreciated, I am already out of cards at this moment and this functionality is urgent for the app.
  • Diana4998Diana4998 Posts: 2
    NerveGear
    I don't know where persistentDataPath is either, I tried to create a folder, then search for it, but found nothing, so I have no idea how to access files. I just want to put files on Oculus Go, and read it. Can anybody help me at all?
  • ScottiedeanScottiedean Posts: 4
    NerveGear
    @doudoid I got this to work when just having one video but when I put more then one the videos would not play. I tried the READ_EXTERNAL_STORAGE in terminal and added the _360. Also I tried putting them into separate folders and nothing worked. Any Advise?

  • jessephoriajessephoria Posts: 2
    NerveGear
    I've had recent luck with reading/writing from (in unity)  Application.persistentDataPath in conjuction with Path.Combine
    to format the path correctly:

    path = Path.Combine(Application.persistentDataPath, "file.txt")
Sign In or Register to comment.