No audio in Shipping build — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

No audio in Shipping build

localstarlightlocalstarlight Posts: 26
Brain Burst
In my Unreal project (4.18.3) the audio is working fine while playing in the editor, but doesn't work (it's completely silent) in a Shipping build.

If I use the Vive instead of the Rift with the exact same Shipping build the audio works fine, so it's definitely an issue with Oculus.

I have tried running the shipping build from my hard drive, but have also uploaded it to the Alpha Release Channel for my project and downloaded it and played it through the Oculus store with the same result.

The build is successful, but it does include these lines in the Output Log, which seem like they might be relevant:

 [OVRPlugin][ERROR] ovr_GetAudioDeviceInGuidStr failed:
 [OVRPlugin][ERROR] Cannot get preferred VR audio IN device.[OVRPlugin][ERROR] ovr_GetAudioDeviceOutGuidStr failed:

Has anyone else experienced this, and knows how to fix it?

Comments

  • lucastakejamelucastakejame Posts: 6 Oculus Start Member
    I'm having the same issue. Running oculus Validation script on the audio section returns that the audio always goes to windows default output.
    Tried other builds with:
    -Setting Audio Device to 'Headphones (Rift Audio)' (makes validation test fail saying it shouldn't play through oculus phones in the first time)
     -Audio spatialization plugin ( I know it shouldn't affect but I have no idea anymore)

     Couldn't figure out how to fix yet, any news on that @imperativity?

  • lucastakejamelucastakejame Posts: 6 Oculus Start Member
    edited August 2018
    @imperativity, audio in fact goes through defaultAudioDevice in both audio modes :/.

    This is the test output:

    OculusVRCValidator.exe" --path ".\WindowsNoEditor\ApocalypseRider.exe" --test TestAudioOutput
    Starting TestAudioOutput
    Disable audio mirroring
    Setting audio mode to Windows
    Waiting for the application to run for 5 seconds before testing begins...
    Starting test...
    Application played sound thru default audio device
    Setting audio mode to Rift
    Waiting for the application to run for 5 seconds before testing begins...
    Starting test...
    ERROR: Application should not have played sound thru defaultDevice
    Cleaning up...
    Test FAILED
    Summary:
    TestAudioOutput: Failed
    Generated by OculusVRCValidator version 1.28.0.0

    This is and output of packaging (With UE4) process that seemed related:

    UATHelper: Packaging (Windows (64-bit)):   Execution of commandlet took:  47.29 seconds
    UATHelper: Packaging (Windows (64-bit)):   OculusIAP: Warning: module shutdown
    UATHelper: Packaging (Windows (64-bit)):   LogOnline: Display: Oculus: FOnlineSubsystemOculus::Shutdown()
    UATHelper: Packaging (Windows (64-bit)):   [OVRPlugin][ERROR] ovr_GetAudioDeviceInGuidStr failed:
    UATHelper: Packaging (Windows (64-bit)):   [OVRPlugin][ERROR] Cannot get preferred VR audio IN device.[OVRPlugin][ERROR] ovr_GetAudioDeviceOutGuidStr failed:
    UATHelper: Packaging (Windows (64-bit)):   [OVRPlugin][INFO] [CAPI] LibOVR module is located at C:\Program Files\Oculus\Support\oculus-runtime\LibOVRRT64_1.dll[OVRPlugin][INFO] Connected to the server running version (prod = 1).1.28.0(build = 633101) feature version = 0. Client runs version (prod = 1).1.28.0(build = 0) feature version = 0[OVRPlugin][INFO] IA
    D changed to 58.5mm
    UATHelper: Packaging (Windows (64-bit)):   [OVRPlugin][ERROR] Cannot get preferred VR audio OUT device.

  • juanoldinhojuanoldinho Posts: 131 Oculus Staff
    edited August 2018
    Hi @lucastakejame,

    I believe you will need to leave the Audio Device field blank, in your UE Project settings. I attached an image of the settings I have used with an app that succesfully passed this test.


    Please tag me, @juanoldinho, in your forum post/response if you need immediate assistance or want additional support or context on an issue you are having with our software or integrations.

    Having an issue with our platform, services, or integrations?

    Try using our new bug tool to report this and receive emailed updates as we proceed to address it internally.
  • lucastakejamelucastakejame Posts: 6 Oculus Start Member
    @juanoldinho This is my current config, I just tried setting to  'Headphones (Rift Audio)' in that test.
  • lucastakejamelucastakejame Posts: 6 Oculus Start Member
    [SOLVED] (with caveats): I checked my project settings and the option 'bStartInVR' was set to false. When I changed to true, oculus validation audio test worked, but the caveat is that this flag crashes UE4 on launch (at least on 4.18 which is the one I'm using). So its more of a UE4 problem but this should be noted anyway, thanks for the attention @juanoldinho ; and @imperativity ; !
  • lucastakejamelucastakejame Posts: 6 Oculus Start Member
    I'm having the same issue. Running oculus Validation script on the audio section fails and returns that the audio always goes to windows default output.
    Tried other builds with:
    -Setting Audio Device to 'Headphones (Rift Audio)' (makes validation test fail saying it shouldn't play through oculus phones in the first time)
     -Audio spatialization plugin ( I know it shouldn't affect but I have no idea anymore)

     Couldn't figure out how to fix yet, any news on that @imperativity?

  • lucastakejamelucastakejame Posts: 6 Oculus Start Member
    I'm having the same issue. Running oculus Validation script on the audio section fails and returns that the audio always goes to windows default output.
    Tried other builds with:
    -Setting Audio Device to 'Headphones (Rift Audio)' (makes validation test fail saying it shouldn't play through oculus phones in the first time)
     -Audio spatialization plugin ( I know it shouldn't affect but I have no idea anymore)

     Couldn't figure out how to fix yet, any news on that @imperativity?

Sign In or Register to comment.