How do I get the Mirror sample to start working? — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

How do I get the Mirror sample to start working?

I am trying to better understand the provided Mirror sample in order to figure out how to render the Avatar hand and controller models using OpenGL and Native C++. However, I haven't been able to run the generated executable Mirror.exe to see how it works. I am using Visual Studio 2017, so I updated generate_projects.cmd accordingly to this:
@cmake -G "Visual Studio 15 2017 Win64" -H. -BVS2013

And this correctly generates the Mirror.exe file. However, when I try to run it, a blank white window pops up with the text "Mirror startup error: Failed to open shader files", along with the following details from the debug window:

GetSignatureToken get_signature error: OVR6139226: Missing entitlement for [APP_ID] (1971031)

GetUserID failed: OVR35993423: Must call get_signature first (1971051)

OAF response error [WindowsPlatform::GetGKValue]: OVRxxx: Must call get_signature first (1971051)

Failed to fetch FBNS credentials from OAF: OVRxxx: Must call get_signature first (1971051)

requestOafRoomUpdate response error: OVRxxx: Must call get_signature first (1971051)

requestOafLaunchDetailsUpdate response error: OVRxxx: Must call get_signature first (1971051)

Failed to set FBNS credentials: OVRxxx: Must call get_signature first (1971051)


I have tried creating a new app under my account and changing the default mirror sample app id to the new one, but the same error still pops up. It would be helpful to get a possible solution to this problem, a functioning Mirror.exe, or even just a video showing off the the sample's functionality. Any help would be appreciated!

Answers

  • zhouizhoui Posts: 3
    NerveGear
    @imperativity I am using the latest version of the Avatar SDK (1.26.0). I actually managed to solve the problem; turns out one of the shader files was missing from the directory containing Mirror.exe (AvatarFragmentShader_CombinedMesh.glsl), so the program could not find it. After copy-pasting the missing file from ReferenceShaders, the sample started working properly.
Sign In or Register to comment.