Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

OVRInput and Input blocked when virtual reality support is disabled

svennevesvenneve Posts: 8
NerveGear
edited June 2018 in Unity Development
When I try to test a 2D / desktop mode version of our game built in Unity using the OVRInput class for player input with virtual reality support disabled, ALL input seems to be blocked (all inputs return false or 0).
(On top of that when VR is disabled OVRPlugin endlessly spews the famous 'ovrp_GetAppHasInputFocus return Failure_NotInitialized' warning', I thought this was fixed at some point?)

Is this a bug? Am I doing something wrong?

Unity 2017.2.0f3 with Oculus Utilities 1.21.0.

Comments

  • svennevesvenneve Posts: 8
    NerveGear
    Okay, 'solved' it, so in case anyone runs into this, here's the run down.

    It seems in order to run desktop mode, you need to build with virtual reality support enabled, and start your build with '-vrmode none' (which didn't work), but what the manual fails to mention and the Oculus' 'Use Required Project Settings' script fails to do though, is adding the 'None' Virtual Reality SDK in your PlayerSettings.

    And since OVRInput needs to have a HMD present or it will simply fail, building with virtual reality support enabled makes sure OVRInput will work.
  • NinjaGGNinjaGG Posts: 234 Oculus Staff
    @svenneve Thank you for the info and update! This is good feedback for us to add to our body of knowledge.
    If you need immediate help or want additional support/context on an issue you are having with our platform or integrations:

    1. Gather any and all logs, screenshots, and version numbers of relevant software (Oculus SDK, engine, etc.)
    2. Please submit a ticket here (include what you've gathered in step 1).
    3. Tag me @NinjaGaijin once you have done so!
Sign In or Register to comment.