Trouble finding Oculus Go app in Library on device — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Trouble finding Oculus Go app in Library on device

Hello.

We have developed an app for Oculus Go and added it to the Library for users to test. However, the app does not appear. The devices have been set in dev mode to view all apps. Are there special settings to consider when making an app visible in the Library?

Additionally, we have tried sideloading the app but it crashes immediately. It seems there is a licensing problem with trying to sideload apps for testing.
Tagged:

Comments

  • NinjaGGNinjaGG Posts: 221 Oculus Staff
    @vromerodf

    Thanks for reaching out! Have you uploaded your build to a release channel and invited your desired users to that channel? Which engine are you developing in?
    If you need immediate help or want additional support/context on an issue you are having with our platform or integrations:

    1. Gather any and all logs, screenshots, and version numbers of relevant software (Oculus SDK, engine, etc.)
    2. Please submit a ticket here (include what you've gathered in step 1).
    3. Tag me @NinjaGaijin once you have done so!
  • nickfourtimesnickfourtimes Posts: 18
    NerveGear
    I'm working with the OP and I've pushed the game to several release channels – STORE and ALPHA, for testing with our Oculus contacts, as well as a few more channels that I created for internal use. I've sent out the invites, and we're all listed as "Subscribed Users," but the game wasn't showing up in our Libraries (whether under "Not Installed" or "My Preview Apps.")

    We've got an email thread going with our Oculus reps, and it looks like the build was reporting as using an SDK < 1.0, and so Oculus Go was disabled as a target device. We're using Unity 2017.3.1f1 and the utilities for Unity plugin 1.24.0, so this seems like a bug. 

    Our rep was able to copy our build from the STORE channel (where the Go was listed correctly as a target device) and put it into our BETA channel, and that seemed to propagate to subscribed users. However, that STORE build had various bugs and cert fails, and I'm still not sure how to upload a new build and have it propagate to our QA folks.
  • NinjaGGNinjaGG Posts: 221 Oculus Staff
    @nrudzicz Thanks for the update. Since you have an ongoing correspondence with a representative, we encourage you to continue through that avenue. If there is an update you'd like to share with us here, please feel free to.
    If you need immediate help or want additional support/context on an issue you are having with our platform or integrations:

    1. Gather any and all logs, screenshots, and version numbers of relevant software (Oculus SDK, engine, etc.)
    2. Please submit a ticket here (include what you've gathered in step 1).
    3. Tag me @NinjaGaijin once you have done so!
  • kimley-hornVRkimley-hornVR Posts: 3
    NerveGear
    Hi, 
    We are having the same issue here. We published with UE4.21.3. I am the only user able to see the alpha build in my preview apps. Any help is appreciated. It seems like there are a few threads on this issue but no resolution. 

    Thanks!
  • LululutesLululutes Posts: 1
    NerveGear
    Newbie trying to install Oculus, says I need to update drivers by going to the Oculus Library on my PC. Only problem, there isn't one. I am in a loop and frustrated. Help!
Sign In or Register to comment.