Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

[SOLVED] Entitlement in ue4 4.19 not working?

wirelitesoft.devwirelitesoft.dev Posts: 181 Oculus Start Member
edited June 2018 in Unreal Development
Hello, this is my first post on the forums. I added the registry key, added the text to my defaultengine.ini
added the entitlement node to my level bp. I am logged in my oculus however I'm getting this error:

LogOnline: Display: Oculus: FOnlineSubsystemOculus::InitWithWindowsPlatform()
LogOnline: Warning: Oculus: Failed Oculus login. Not currently logged into Oculus.  Make sure Oculus is running and you are entitled to the app.
LogOnline: Error: Oculus: Failed the entitlement check: OVR6139226: Missing entitlement for <CENCORED> (CENSORED)

Here are some screens of my setup:
reg key added:



subsystem added to DefaultEngine.ini



And the bp node in my level bp:





But still It errors out. It wont let me compile the game without this error. How can i upload the app if im getting this error?
Please help me so i can release my first game for free in early access on the app store?
i have everything ready but this error is annoying me and i can't seem to fix it.

Comments

  • wirelitesoft.devwirelitesoft.dev Posts: 181 Oculus Start Member
    I have solved the issue myself. You guys need to edit your documentation for unreal....
    the issue was that NOWHERE does it say to remove the <> marks in the code that you guys give
    to add to the DefaultEngine.ini.... In the code it gives you to paste it has the <> marks so a new user is going to add them too. PLEASE FIX YOUR SNIPPET CODE TO NOT HAVE THE <> MARKS.....
Sign In or Register to comment.