Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Beat Saber not launching

mark.keohanemark.keohane Posts: 2
So recently i bought beat saber (unity) on steam and whenever i tried to play it, it would take m into the splash screen in the headset, and then just return me to steam vr home. i had had enough so  i refunded it and bought it on oculus instead, but it still doesn't launch. i've tried disabling firewalls and turning off anti virus but it still doesnt work. All my other games work and this is just getting annoying, if anyone has some fixes or ideas, please tell me. i cant find any logs of the crashes so im pretty stuck here. My Pc has 16gb ddr4 running at 2666, a 1070 8gb and an 8700k.


  • PsynogPsynog Posts: 1
    I have the exact same issue
  • cybertec02cybertec02 Posts: 2
    same issue here, i emailed beatsaber support, no reply
  • NorseMonsterNorseMonster Posts: 5
    Same issue with Beat Saber AND Arizona Sunshine.  Some games work just fine, but these two I get the same exact issue, splash screen with less than a second load time then it disappears and puts me right back to home screen with no error message.
  • DarkShamanDarkShaman Posts: 2
    Having the same issue here with Beat Saber.  Bought the app Jan 1, 2019 and about 2 days ago it stopped working.  Says it is loading, then goes back to the home screen.  All other apps work fine.  Purchased from Oculus.  Have uninstalled/re-installed program, shut off firewalls and virus scanner with no luck.
Sign In or Register to comment.