Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

OculusTrcValidator fails and OculusDebugTool crashes

I am trying to test an app using the OculusTrcValidator before uploading it to the Oculus Store.  When I run the Validator:

$ ./OculusTrcValidator.exe --path "/c/Program\ Files/High\ Fidelity\interface.exe" -v

Almost all of the tests fail like this:

Starting TestSdkVersion
Sending message to OAF: {"requestData":{"wearing_hmd":true},"requestName":"/life_cycle/proximity_sensor","sequenceId":"128"}
Response from OAF: {"messageType":"RESPONSE","payload":{"value":"OK"},"payloadType":"PLAIN_STRING","sequenceId":"128","timestamp":"1540425588143"}

ERROR: Application launch was cancelled
ERROR: Setup test failed because application couldn't be started. HRESULT: 1223
Cleaning up...
Sending message to OAF: {"requestData":{"wearing_hmd":false},"requestName":"/life_cycle/proximity_sensor","sequenceId":"129"}
Response from OAF: {"messageType":"RESPONSE","payload":{"value":"OK"},"payloadType":"PLAIN_STRING","sequenceId":"129","timestamp":"1540425588219"}

Test FAILED

The same thing happens when I try to validate an app that I've downloaded from the Oculus Store, so it's not an issue with the application I'm testing.

I've tried to use the OculusDebugTool GUI to do it, but it crashes very quickly if I open "Validate App" and try to do anything (choose a file, select a test, run, etc.).

Does anyone have any advice?  Thank you.

Comments

Sign In or Register to comment.