Submission rejected for distortion problem on AMD 290 — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Submission rejected for distortion problem on AMD 290

VinzVinz Posts: 3
NerveGear
Hi everyone, i have a problem with the submission of my build and i hope someone can help me or put me in the right direction.
My game is for the Rift, my build pass every test performance but failed only on VR PC PERFORMANCE 7 with this explanation :
"*This issue only occurs on the AMD 290 Black distortion is displayed throughout the application." 
All other tests are OK, included the frame rate test on both GTX970 and AMD290.

I used Unreal 4.20 for my game and i have not change anything in the source code Engine, and i dont have any  special post process.
And as it says in the Oculus VR Guideline, the VR.PC.PERFORMANCE7 should  be "less a concern for unity and unreal developers  because our game engine integration always uses correct convergence".
As all frame rate test succeed, it dont feel to me as a performance issue due to the asset of the game.
 So i m very confused , i dont know from where the problem came from.

The people from oculus submission just say to me to use the oculus profiler but i dont have this specific AMD card and no access to it, i have only do extensive testing with GTX970, GTX980, GTX1070mobile and GTX1080 with no problem at all with any of those card.
Amd290 is  not in sale anymore in my country so its quite hard to find... 
So if anyone had a similar problem or can help me ...
Thanks a lot

Comments

  • abydosanabydosan Posts: 20
    Brain Burst
    edited November 2018
    This problem appeared from UE 4.20 and as I know all RX AMD card has this problem (my card is RX480). If you able to change back to 4.19 the VR will working well on AMD cards :(

    Update: Maybe a temp solution. I don't know https://issues.unrealengine.com/issue/UE-64034
  • VinzVinz Posts: 3
    NerveGear
    Thanks a lot abydosan for your informations, it s exactly my problem.
     Unfortunately i cant go back to 4.19 but i will try the temp solution that you give in your update.
     Thanks again
  • VTBVTB Posts: 1
    NerveGear
    edited March 12
    Looks like there is solution: https://issues.unrealengine.com/issue/UE-64034

    The easiest way is to put those lines into DefaultEngine.ini
    [Oculus.Settings]
    bCompositeDepth=False
Sign In or Register to comment.