Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums will be revoked at the discretion of Oculus staff.
New to the forums? Click here to read the How To guide. -- Developers click here.

Hand meshes completely dark, don't respond to lighting

Hi there,
I'm fairly new to working with both Unity and Oculus, and I've stumbled upon a problem that I just can't seem to fix. The hands in my scene, which directly come from the avatar prefab, simply don't show any texture/colour anymore (instead of the default semi transparent blue), nor do they cast any shadows whatsoever. I've tried fiddling around with the settings, re-importing the package but to no success. If anyone has resolved something similar or has an idea what's going on here that would be greatly appreciated!

Emiel



Comments

  • imperativityimperativity Posts: 3,587 Valuable Player
    @EmielDelft

    Can you check and make sure that your graphics card drivers are fully up to date here? I have seen this issue in the past and it is most always graphic driver related.
  • EmielDelftEmielDelft Posts: 3
    NerveGear
    Thanks @imperativity
    There were updates available, unfortunately it didn't resolve the issue.
  • imperativityimperativity Posts: 3,587 Valuable Player
    @EmielDelft

    What version of Avatar SDK and Unity are you using?

    Also, can you dropbox link me a repro project via private message so I can evaluate this internally?
  • EmielDelftEmielDelft Posts: 3
    NerveGear
    @imperativity

    The most recent version.
    I've come to see that it is an issue with the lighting, the lighting in the scene comes from a few panes with an emission shader. All other objects in the scene have static lightmap enabled, which makes them look just fine. This didn't seem to be an option for the hands, so what I did was add a pointlight to the scene as a workaround. So not a bug, just not a great approach from my side. 
    Thanks for the help!
Sign In or Register to comment.