Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

What's going on with the UE4 4.21 Avatars update?

I've recently decided to add support for Oculus Avatars to my game and at the same time I've migrated my project to 4.21 UE4.  I see in the documentation here https://developer.oculus.com/documentation/avatarsdk/latest/concepts/avatars-gsg-unreal/ that it says support for 4.21 is not there yet.  Trying to get around this I was not able to find the examples project listed in that link as well.  Is this due to there not being official support in 4.21?  Can I get some information about including the ovr avatar plugin needed in UE4 4.21.

Comments

  • RuptureGamesRuptureGames Posts: 20
    NerveGear
    edited December 2018
    Update - Okay so I've found the way to include the plugin (not sure why I didn't think it was as easy as enabling it in the project file, figured I needed to manually include stuff,  which isn't how plugins work). Unfortunately enabling the plugin along with Online Sub Systems causes unreal to crash when I build.  Is this due to the notice in the documentation saying it is not yet ready in 4.21?  If this is the case is there an estimate to when it will be?  This is a really important feature and it seems weird that it's on unity but not UE4 4.21 yet.  

    I get this error when building-

    Unhandled exception at 0x00007FFB17635299 (KernelBase.dll) in UE4Editor-Win64-DebugGame.exe: 0xC06D007E: Module not found (parameters: 0x000000D360ECD690). occurred
  • RuptureGamesRuptureGames Posts: 20
    NerveGear
    Hmm, I figured others would be wondering the same.  I saw in the sticky thread about avatars other people asking about 4.21 support and yet no response on a highly marketed feature for developers?  I'm not sure how I'm supposed to support this feature if I can't access it in UE4.  I'll move onto something else right now but this is a big let down. 
  • Ross_BeefRoss_Beef Posts: 149 Oculus Staff
    edited December 2018
    Hey @RuptureGames,

    My apologies that unfortunately a change in 4.21 was introduced just as we were wrapping up the latest updates to 4.20 and we were therefore unable to confirm that we could support 4.21 in our previous release cycle.

    Good news, however, is that we’ve isolated the issue to the propagation of a dirty joint transform that was introduced, and are working to make sure that a fix will land as soon as possible.

    Once again apologies that we can’t happily say we support 4.21 at this time, but I hope you understand that we’re doing everything possible to remedy this.

    as always, appreciate your feedback and suggestions on how we can build you a better product.
  • Mosel3yMosel3y Posts: 6
    NerveGear
    Hmm, I figured others would be wondering the same.  I saw in the sticky thread about avatars other people asking about 4.21 support and yet no response on a highly marketed feature for developers?  I'm not sure how I'm supposed to support this feature if I can't access it in UE4.  I'll move onto something else right now but this is a big let down. 

    Fyi, It packages for me, but only for Win64. The plugin is only whitelisted for Win64 at the moment. If you're building for Win32 it won't work (I don't think so anyway). Oculus' 4.21 fork also works on Android. I've got Avatars working on the Oculus Go using their fork, although there's a few bugs in it.

    I've got OnlineSubsystem, and OnlineSubsystemOculus plugins enabled in my .uproject, and it's a code project.



  • motorsepmotorsep Posts: 1,342 Oculus Start Member
    Ross_Beef said:
    Hey @RuptureGames,

    My apologies that unfortunately a change in 4.21 was introduced just as we were wrapping up the latest updates to 4.20 and we were therefore unable to confirm that we could support 4.21 in our previous release cycle.

    Good news, however, is that we’ve isolated the issue to the propagation of a dirty joint transform that was introduced, and are working to make sure that a fix will land as soon as possible.

    Once again apologies that we can’t happily say we support 4.21 at this time, but I hope you understand that we’re doing everything possible to remedy this.

    as always, appreciate your feedback and suggestions on how we can build you a better product.
    Do you guys to plan releasing Avatars update with UE 4.21.1 in Oculus branch ?
Sign In or Register to comment.