Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Unity Alert: Crash on older CPUs without AVX (12/21/18)

mfmfmfmf Posts: 55 Oculus Staff
edited January 22 in Unity Development
We've discovered a crash in the audio spatializer Unity plugin DLL on older CPUs without AVX. (The CPUs are officially unsupported, but we recognize that some users will still attempt to run Oculus software on them, resulting in developer support requests.)

YOU MAY GET THIS CRASH EVEN IF YOU'RE NOT USING THE AUDIO SPATIALIZER. Unity can load the DLL at runtime even if it's not used. Furthermore, in Unity, this crash will terminate the program before any diagnostic information is written to the output logs, making this somewhat difficult to identify. 

The workaround for this crash is to remove the DLL from your build.

Comments

This discussion has been closed.