[Unreal] Unable to join session — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

[Unreal] Unable to join session

MrComfortMrComfort Posts: 28
Brain Burst
edited January 8 in Unreal Development
I read in the forum that there were some updates/fixes regarding Oculus Sub Systems so I tried to create and join a session today (create session with a "Browse Pool" and joining via "Join Session", all via blueprints) and after finding the session I (still) can not join the session with the client (no connection is being established and no map is being opened).
I was using the Unreal Studio multiplayer project preset and simply changed the relevant session nodes to the Oculus BP nodes.
I also changed the DefaultEngine.ini, added the entitlement check and activated the Oculus Sub System Plugin.
Unreal version 4.21.1 (Epic Launcher version)
I packaged the project for testing so it should not be using the wrong net driver.
Attached you can find the logs and my Engine.ini file.
Here are the project files if anybody wants to have a look at them: http://gofile.me/3trey/KMSNNsOFb
Does anybody know, what I need to change to get it to work?


  • NeontopNeontop Posts: 212 Oculus Start Member
    edited January 8
    Hi @MrComfort
    I suggest you to check with the ue4.21.1 of the  Epic Launcher version
    which is the Oculus Platform SDK version and download it.Inside there will be an UE4 example project which explains:  session,Matchmaking..etc.

  • MrComfortMrComfort Posts: 28
    Brain Burst
    Thanks for your reply. I already tried the sample project back in 4.20 and now with 4.21.1 again and it does not work for me. I just read a post about trying the github engine version so maybe that works then.
  • PixelChaosPixelChaos Posts: 1
    I encountered the issue of being unable to join a session in 4.21 too. In 4.20 it works fine, when the ini is set up properly. In 4.21 the JoinSession node returns that joining the session was successful, but the client travel function doesn't seem to be processing properly. The map does not instantly reload onto the server's map. It takes a good while, then the client restarts with the correct session still active, but the server never registers that the client joined. Both then are in the same correct session and the session player count is 2 but they are not in the same game/map.

    The project is C++ and using Epics 4.21.2. When trying to build the Oculus version, it compiles properly, but on trying to open the project files it requires to rebuild the engine again and ends with an error, that I couldn't resolve. So I can only test and open it with Epics 4.21.2 so far.
Sign In or Register to comment.