Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Using the Oculus Integration with Unity 2018.3.x.

pgravespgraves Posts: 3 Oculus Staff
edited January 31 in Unity Development

The Oculus Integration is incompatible with the latest versions of the Unity Editor (2018.3.x). We do not recommend using any 2018.3.x versions for Oculus development.

If you choose to use 2018.3.x and/or need to fix your project already in 2018.3.x, here are the workaround steps:

- Follow the steps on Importing the Oculus Utilities Package (https://developer.oculus.com/documentation/unity/latest/concepts/unity-import/) to remove the existing Oculus Integration package.

- Open your project and navigate to the Package Manager (Windows / Package Manager). Then install the Oculus (Standalone) package (it will be an older version #, probably 1.29.0). Do NOT install the Oculus (Android) package.

- Open the Asset Store tab and import the Oculus Integration, now 1.32.1.

Comments

  • mlDFmlDF Posts: 1
    NerveGear
    Not sure what's the issue here. I've developed an Oculus GO / Gear VR application using Unity 2018.3 and I just downloaded the Oculus Unity Intergration package and imported it and I am using the Oculus (Android) package from the package manager. Did not notice any issues so far... What am I doing wrong? :neutral:

  • jinhaifengjinhaifeng Posts: 6
    NerveGear
    any word on said incompatibilities with unity 2019.1a?
  • NinjaGGNinjaGG Posts: 230 Oculus Staff
    v1.34 of our integration has been released. We highly encourage developers who are using v1.32 of our integration to upgrade to v1.34. Developers using previous Unity 2018.3 versions, we also encourage you to upgrade to Unity 2018.3.3f1 immediately due to compatibility issues. You can read more about this here.
    If you need immediate help or want additional support/context on an issue you are having with our platform or integrations:

    1. Gather any and all logs, screenshots, and version numbers of relevant software (Oculus SDK, engine, etc.)
    2. Please submit a ticket here (include what you've gathered in step 1).
    3. Tag me @NinjaGaijin once you have done so!
  • BloodyOculusBloodyOculus Posts: 19
    NerveGear
    is everything good now?
  • MigothMigoth Posts: 2
    NerveGear
    is everything good now?

  • ChalyjChalyj Posts: 2
    NerveGear
    edited March 28
    hey! I'm trying to make vr app for GearVR from the tutorial at  developer.oculus.com/documentation/unity/latest/concepts/unity-tutorial/ with Unity 2018.3.10f1 and Oculus Integration 1.35. I have no problem on Samsung S9, but on Samsung S7 (Android 8.0.0) in logcat I receive "W/ActivityManager: GearVR not ready: not allowed to start VR Activity. activity=ComponentInfo{com.oculus.mytest/com.unity3d.player.UnityPlayerActivity} intent=Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10000000 pkg=com.oculus.mytest cmp=com.oculus.mytest/com.unity3d.player.UnityPlayerActivity }. So app does not start.
  • stevehinanstevehinan Posts: 129
    Art3mis
    Chalyj said:
    [android.intent.category.LAUNCHER]
    If related to uploading a store build, try removing from the AndroidManifest.xml:
    <category android:name="android.intent.category.LAUNCHER"/>


  • VRPlayersVRPlayers Posts: 2
    NerveGear
    edited March 29


  • ChalyjChalyj Posts: 2
    NerveGear
    If related to uploading a store build....
    Unfortunately not. I tried to switch from Unity 2017 to Unity 2018 with our main project. But I got this error. I thought it was some kind of mistake in the project. But a new simple VR app from scratch has the same error...
Sign In or Register to comment.