Update in progress and not running app — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Update in progress and not running app

SerchdoubleSerchdouble Posts: 1
NerveGear
Hi! im trying to test an app for oculus go in unity but when I build up and run in the oculus go pups up an ad that say update in progress and doesnt run. any solutions here?

Comments

  • artfabrikartfabrik Posts: 1
    NerveGear
    Can confirm... Have the exact same problem.
    I'm running
    Version: 3.54.33.131643470
    Runtime Version: 3.6.3.130862347
    on the Oculus Go (which I hope is the most recent, as I have no possibility to check whats the most recent version...)
    with current Unity 2018.3.6 and recent Oculus Integration 1.34

    I tried quite a lot, like switching between different backend versions (mono, IL2CPP), different build targets (ARM64, armeabi-v7a) but it all ends in the same problem as described in the post above.

    I have noticed another problem (maybe related?): the logcat of adb spits out the following, as you can see, libAudioPluginOculusSpatializer is not found (although I tried here quite a lot too):
    02-15 22:46:06.703  3289  3304 I Unity   : SystemInfo CPU = ARMv7 VFPv3 NEON, Cores = 4, Memory = 2733mb
    02-15 22:46:06.703  3289  3304 I Unity   : SystemInfo ARM big.LITTLE configuration: 2 big (mask: 0xc), 2 little (mask: 0x3)
    02-15 22:46:06.704  3289  3304 I Unity   : ApplicationInfo com.unity.app version 1.0 build eeb3517f-e5e7-4937-98a4-8def6bcb6752
    02-15 22:46:06.704  3289  3304 I Unity   : Built from '2018.3/release' branch, Version '2018.3.6f1 (a220877bc173)', Build type 'Release', Scripting Backend 'mono', CPU 'armeabi-v7a'
    02-15 22:46:06.847  3289  3304 E Unity   : Unable to find libAudioPluginOculusSpatializer
    02-15 22:46:06.887  3289  3304 D Unity   :  GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_sync GL_OES_vertex_half_float GL_OES_framebuffer_object GL_OES_rgb8_rgba8 GL_OES_compressed_ETC1_RGB8_texture GL_AMD_compressed_ATC_texture GL_KHR_texture_compression_astc_ldr GL_KHR_texture_compression_astc_hdr GL_OES_texture_compression_astc GL_OES_texture_npot GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_OES_texture_3D GL_EXT_color_buffer_float GL_EXT_color_buffer_half_float GL_QCOM_alpha_test GL_OES_depth24 GL_OES_packed_depth_stencil GL_OES_depth_texture GL_OES_depth_texture_cube_map GL_EXT_sRGB GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_EXT_texture_type_2_10_10_10_REV GL_EXT_texture_sRGB_decode GL_EXT_texture_format_sRGB_override GL_OES_element_index_uint GL_EXT_copy_image GL_EXT_geometry_shader GL_EXT_tessellation_shader GL_OES_texture_stencil8 GL_EXT_shader_io_blocks GL_OES_shader_image_atomic GL_OES_sample_variables GL_EXT_texture_border_clamp GL_EXT_EGL_i
    02-15 22:46:06.887  3289  3304 D Unity   : mage_external_wrap_modes GL_EXT_multisampled_render_to_texture GL_EXT_multisampled_render_to_texture2 GL_OES_shader_multisample_interpolation GL_EXT_texture_cube_map_array GL_EXT_draw_buffers_indexed GL_EXT_gpu_shader5 GL_EXT_robustness GL_EXT_texture_buffer GL_EXT_shader_framebuffer_fetch GL_ARM_shader_framebuffer_fetch_depth_stencil GL_OES_texture_storage_multisample_2d_array GL_OES_sample_shading GL_OES_get_program_binary GL_EXT_debug_label GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent GL_QCOM_tiled_rendering GL_ANDROID_extension_pack_es31a GL_EXT_primitive_bounding_box GL_OES_standard_derivatives GL_OES_vertex_array_object GL_EXT_disjoint_timer_query GL_KHR_debug GL_EXT_YUV_target GL_EXT_sRGB_write_control GL_EXT_texture_norm16 GL_EXT_discard_framebuffer GL_OES_surfaceless_context GL_OVR_multiview GL_OVR_multiview2 GL_EXT_texture_sRGB_R8 GL_KHR_no_error GL_EXT_debug_marker GL_OES_EGL_image_external_essl3 GL_OVR_multiview_multisampled_render_to_texture GL_EXT_buffer_storage GL_EXT
    02-15 22:46:06.887  3289  3304 D Unity   : _external_buffer GL_EXT_blit_framebuffer_params GL_EXT_clip_cull_distance GL_EXT_protected_textures GL_EXT_shader_non_constant_global_initializers GL_QCOM_texture_foveated GL_QCOM_shader_framebuffer_fetch_noncoherent GL_EXT_memory_object GL_EXT_memory_object_fd GL_EXT_EGL_image_array GL_NV_shader_noperspective_interpolation GL_KHR_robust_buffer_access_behavior GL_EXT_EGL_image_storage GL_EXT_blend_func_extended GL_EXT_clip_control

  • IlanbIlanb Posts: 5
    NerveGear
    Same error for me, updated four oculusGo, for some app working immediatly, for other message update in progress and doesnt run... After sometimes (oculus turned on) app works... I really don't understand why... I realy like if Oculus team was better than that... Easy for us to put some application Keys only... BUT Oculus team need to make a better product first !!! 
  • naoto.yoshioka.14naoto.yoshioka.14 Posts: 2
    NerveGear
    Exactly same error for me.  I have two Oculus Go, one works fine, but another doesn't.
  • naoto.yoshioka.14naoto.yoshioka.14 Posts: 2
    NerveGear
    After 30 minutes break, it start working...
  • d_rad_ra Posts: 1
    NerveGear
    I ran into this as well and restarting my Go fixed it.
  • hacarohacaro Posts: 3 Oculus Start Member
    Same for me, at the moment i've tried a lot of restart but nothing. Any Oculus developer here that can reply to this issue ? 
  • TakeawalkerTakeawalker Posts: 2
    NerveGear
    Have the same issue, trying to update/install from the store via a beta channel. We have a lot of headsets testing, and it seems completely random which ones work, and which ones get the message. Also, sometimes restarting seems to fix it, sometimes nothing helps. Sometimes I can't even uninstall the app without using ADB.

    This is really bad for business...
  • karelkarel Posts: 52
    Hiro Protagonist
    Just stumbled onto this problem. Anyone found any solution to this?  Oculus help? Dont ignore this issue, i dont have time or energy to deal with this BS again. I have time sensitive project that i need to deliver and now i randomly have this issue. I have made so many builds and never had a problem like this before. 

  • mattyeatsmattsmattyeatsmatts Posts: 5
    NerveGear
    Just tried to use my oculus go for the first time in 6 months but have the wait for update thing. Ive waited 1.5hrs so far. Looks like its back in the cupboard for another 6 months and devo coz i just wasted $15 on a game. Should have called it an Oculus NoGo
Sign In or Register to comment.