Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Rubberbanding Locomotion Unity

So I'm quite new to VR development and working with the Oculus. In my project (Unity) I'm using Oculus Intergration from the Asset Store. In there is the Locomotion prefab that Im trying to use. It works but I've run in some problems I can't seem to solve. The first problem is that the Player seems to rubberband from time to time. When I try to teleport to a certain destination it moves back to a different location. Also a problem is that the teleport doesnt always work. If I push the thumbstick forward the laser shows up, but when I let go it doesn't teleport like it does usually. 

I hope someone can help me!

Comments

  • trevorgravityjacktrevorgravityjack Posts: 0
    NerveGear
    Have the same issue with player in locomotion example scene rubberbanding on average perhaps 1/4 of the time. Have tried to isolate but can't seem to find the source. This happens in a fresh import with:
    Unity 2018.3.6f1
    Oculus Integration 1.35
    Unity Oculus 1.29.1 packages for desktop and android.
    Issue exists with Oculus Rift in editor and Oculus Go on device
    Windows 10

    I too would much appreciate some help with this. Thanks.
Sign In or Register to comment.