Android Manifest & Create Store-compatible Manifest in OVRPlugin 1.35.0 in Unity 2018.3 — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Android Manifest & Create Store-compatible Manifest in OVRPlugin 1.35.0 in Unity 2018.3

nothingadnothingad Posts: 11
NerveGear
edited March 8 in General Development
Hey there,
i have the following problem.. i updated the OVR Framework to version 1.35.0 and created a store-compatible android manifest. We are working with Unity 2018.3.6f1 and building apk for Oculus Go. First issue i came across was, when using the internal build system for android, there pops up a "can't merge android manifest window" (but there is only one manifest in our project) switching to gradle build system helped with this issue.

The next problem is, our apk is bigger than 200mb so we switched to the ovrPlatform Utility, to upload the apk this way. Now we having the issue that our AndroidManifest is not valid.. in the log file i get the following error

log_level":"WARN","event_name":"USER_ERROR","stack_trace":"UserVisibleError: Während der Überprüfung haben wir ein Problem bei der APK-Datei festgestellt. Bitte stelle sicher, dass die APK-Datei unseren Anforderungen für Anwendungs-Manifeste entspricht und sende deine App erneut.\n\n* „Exclude from Recents“ (android:excludeFromRecents in AndroidManifest.xml) muss auf „True“ gesetzt sein.\n* APK main activity intent filter set to `android.intent.category.LAUNCHER`, but must be `android.intent.category.INFO`. Your app must only appear in Oculus Home. It must not appear in the phone’s launcher.\n 

I wonder why the generated manifest doesn't get included into the build apk...
@NinjaGaijin any idea or hints?

thanks in advance and best regards

david
Sign In or Register to comment.