Teleportation blasts me out into space... sometimes. — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Teleportation blasts me out into space... sometimes.

imjusthereimjusthere Posts: 5
NerveGear
I'm using unity 2018.3.7f1 with oculus integration 1.35 and oculus (desktop) 1.29.1. In any of the demo scenes when I teleport about half the time it will shoot my playercontroller out into space. The other half it works fine. It acts as though it's colliding with something and applying a huge horizontal force causing the playercontroller to slide right off the ground plane. You can't teleport off the ground plane so that's not what's happening. I added some walls to keep me from flying out into space but for the life of me I can't figure out what's going on.

Comments

  • imjusthereimjusthere Posts: 5
    NerveGear
    I'm getting the same issue on Unity 2018.3.0f2, 2018.3.8f1, 2018.3.7f1, and 2019.2.0a6. Unity 2018.2.0f2 works though.
  • imjusthereimjusthere Posts: 5
    NerveGear
    For now I am commenting out the following line in LocomotionTeleport.cs in the function DoTeleport(). This makes the glitch go away. I'm not sure yet if this is going to cause me any other problems but it gets me working for now.

    788| LocomotionController.PlayerController.Teleported = true;
  • AlexLeggAlexLegg Posts: 5
    NerveGear
    Super helpful, thank you,  was having the same issue on Quest. Have you found any side effects yet?
  • NinjaGGNinjaGG Posts: 216 Oculus Staff
    edited June 26
    You may want to increase the "Fixed Timestep" value (within the Unity editor, under the Edit -> Project Settings -> Time menu) to match the max framerate of your device. This value determines the rate at which your physics objects update; this is set to 0.2 as default within Unity (50Hz). You can refer to the following chart to determine which values to enter based on device:

    50Hz (Default) = 0.2
    60Hz (Gear VR) = 0.0167
    72Hz (Quest/Oculus Go) = 0.0138
    80Hz (Rift S) = 0.125
    90Hz (Rift) = 0.0111

    This not only makes the physics within your experience smoother, but it also solves the issues around teleporting.
    If you need immediate help or want additional support/context on an issue you are having with our platform or integrations:

    1. Gather any and all logs, screenshots, and version numbers of relevant software (Oculus SDK, engine, etc.)
    2. Please submit a ticket here (include what you've gathered in step 1).
    3. Tag me @NinjaGaijin once you have done so!
Sign In or Register to comment.