All Oculus Quest developers MUST PASS the concept review prior to gaining publishing access to the Quest Store and additional resources. Submit a concept document for review as early in your Quest application development cycle as possible:

For additional information and context, please see "Submitting Your App to the Oculus Quest Store".
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

[UE4] Packaging for Android runs Windows's OnlineSubsystem code


I'm trying to package our Quest app with an AppID to connect with Oculus's online systems. I've followed the instructions here:

And now, upon packaging for Android_ASTC, we're seeing the following line in the output:
LogOnline: Display: Oculus: FOnlineSubsystemOculus::InitWithWindowsPlatform()

LogOnline: Warning: Oculus: Could not find 'RiftAppId' key in engine config.  Trying 'OculusAppId'.  Move your oculus app id to 'RiftAppId' to use in your rift app and make this warning go away.
GetSignatureToken get_signature error: Missing entitlement for 2174122759369539 (1971031)
GetUserID failed: Must call get_signature first (1971051)
OAF response error [WindowsPlatform::GetGKValue]: Must call get_signature first (1971051)
Failed to fetch FBNS credentials from OAF: Must call get_signature first (1971051)
requestOafRoomUpdate response error: Must call get_signature first (1971051)
requestOafLaunchDetailsUpdate response error: Must call get_signature first (1971051)
LogOnlineIdentity: Warning: Oculus: Failed Oculus login. Not currently logged into Oculus.  Make sure Oculus is running and you are entitled to the app.

Why is it going through the Windows code as opposed to Android? What am I missing? Please note that the apk packages fine and our app runs on our Quests.

UE 4.22.1
Oculus VR 1.36.0
Online Subsystem Oculus 1.32.0


  • RhysSulRhysSul Posts: 2
    I was getting a similar issue, try deleting the Oculus Online Subsystem folder from "C:\Program Files\Epic Games\UE_4.22\Engine\Plugins\Online\OnlineSubsystemOculus" and replacing it with one downloaded from source, that fixed it for me I hope it does for you
  • Precision_ShadiPrecision_Shadi Posts: 3
    We're building our own source so I guess that's essentially the same...
  • kcmonkeykcmonkey Posts: 6
    Brain Burst
    We are having the same issue here, Just wondering if you have got it solved...
  • JinuOhJinuOh Posts: 6
    Brain Burst
    Same issue
  • Posts: 47
    Brain Burst
    Anyone know this fix for this?
  • LinsomontLinsomont Posts: 17
    I am facing the same issue. Does anyone know how to fix it? If yes please share as I am having trouble without the solution.
  • Posts: 47
    Brain Burst
    @NinjaGaijin any ideas about this?

  • 7777ivan7777ivan Posts: 3
    I'm currently getting exactly the same message with UE4.24.3 engine provided by Oculus, when building for Quest, but fortunately the build process does not fail.
    Moreover, the entitlement check works in the game startup (by VerifyEntitlement Bp node), but user login always fails (GetOculusIdentity).
    Any idea? Thanks.
    We also have a PC AppID, if I use that there are no building errors, and if I build for Win, both entitlement and user check works fine.
Sign In or Register to comment.