UE4 / Quest / Vulkan - Proper Render/Project Settings? — Oculus
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

UE4 / Quest / Vulkan - Proper Render/Project Settings?

RapidTDRapidTD Posts: 1
NerveGear
Tried creating a simple test project with both the Oculus UE4 branch and Epic's latest 4.22 branch and if I enable Vulkan (ES2 and ES3.1 work fine ) I always get a crash on application launch. Tried all the settings I could find across the various Oculus and Epic documentation. Does anyone have this working currently that could share their basic project settings? Is it just broke in 4.22?

Thanks

Comments

  • imaekgamesimaekgames Posts: 2
    NerveGear
    I too had to disable Vulkan to get my project to NOT crash, I feel your pain, I want that Vulkan performance boost.
  • MaxArchMaxArch Posts: 93
    Hiro Protagonist
    edited June 11
    Same question here:
    On https://developer.oculus.com/blog/down-the-rabbit-hole-w-oculus-quest-the-hardware-software/ it states the Quest supports Vulkan. UE 4.22 also supports Vulkan. So why does even the most simple app deployed on the Quest that uses Vulkan crash at launch?

    Edit: according to this post, you need to disable multi-view and FFR for Vulkan to work. Will test asap but wouldn't fps drop a lot by doing so?

    Edit2: No luck. at least I see my splash screen at loading. Immediate crash afterwards.

    Edit3: apparently it still needs a future Oculus Quest runtime update for Vulkan to work.


  • C4RL05C4RL05 Posts: 1 Oculus Start Member
    Same issue here: Blank project app crashes on launch when Vulkan is enabled.
    But it runs after disabling MultiView (FFR was already off). Also switched on arm64.
Sign In or Register to comment.