IMPORTANT:

All Oculus Quest developers MUST PASS the concept review prior to gaining publishing access to the Quest Store and additional resources. Submit a concept document for review as early in your Quest application development cycle as possible: https://developer.oculus.com/quest-pitch/

For additional information and context, please see "Submitting Your App to the Oculus Quest Store".
Welcome to the Oculus Developer Forums!

Your participation on the forum is subject to the Oculus Code of Conduct.

In general, please be respectful and kind. If you violate the Oculus Code of Conduct, your access to the developer forums may be revoked at the discretion of Oculus staff.

Quest + Unity 2019: APK Signed with Signature Scheme V1

SuppleTeetSuppleTeet Posts: 25
Brain Burst
Hi,

I'm building an apk from Unity 2019.1.0f2 and when I upload to my build dashboard I keep seeing this error:


After doing some research it looks like any version of Unity after 2017.1 should be building with V2. I'm assuming something is old as I'm coming from older Unity versions or maybe something is being overwritten on export...?  

I've tried creating a new keystore and reworking/updating the android manifest with no luck and the build sideloads and runs great.

Before I go down the route of exporting to gradle and building from android studio, does anyone know where I should be investigating?   It'd be awesome to not have to add that extra step.

Lastly, in the docs it says you can sign as v1 if you're targeting GearVR/Go/Quest in one build (or at least it appears that way) so maybe this is an erroneous error?


Thanks!


Tagged:

Comments

  • SuppleTeetSuppleTeet Posts: 25
    Brain Burst
    Hello? Anyone out there?
  • tkeene_vspatialtkeene_vspatial Posts: 10
    NerveGear
    edited June 26
    Seeing the same problem building with 2018.3.12f1.

    I get the same error user SuppleTeet describes above when I upload through the dashboard. The command line utility logs this:

    "ERROR: The APK is signed with deprecated signature scheme V1. Please use V2 or V3 signing for this type of application."

    EDIT: Looks like it accepts my upload if I tweak the AndroidManifest.xml. I set android:targetSdkVersion="26" to 25, and uses-feature android:name="android.hardware.vr.headtracking" android:required="false" to required="true", and then it accepted my build.



Sign In or Register to comment.